toolchain: add support for the internal IBM s390x and Z toolchain
authorAlexander Egorenkov <egorenar@linux.ibm.com>
Thu, 17 Sep 2020 04:07:52 +0000 (06:07 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 24 Sep 2020 20:03:54 +0000 (22:03 +0200)
Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
arch/Config.in
package/gcc/gcc.mk
toolchain/toolchain-buildroot/Config.in

index eb9b6007c9154859d975e462d87ef3843dcc5bc3..155403c3636acfdd877c37571a4968b2d32ea837 100644 (file)
@@ -223,7 +223,6 @@ config BR2_s390x
        bool "s390x"
        select BR2_ARCH_IS_64
        select BR2_ARCH_HAS_MMU_MANDATORY
-       select BR2_ARCH_HAS_NO_TOOLCHAIN_BUILDROOT
        help
          s390x is a big-endian architecture made by IBM.
          http://www.ibm.com/
index df5bf22b96f332ce054277a08d3e571782bf36b6..948fd766468a45b0db149bef6c2baffead5711c5 100644 (file)
@@ -248,6 +248,11 @@ HOST_GCC_COMMON_CONF_OPTS += \
        --with-long-double-128
 endif
 
+ifeq ($(BR2_s390x),y)
+HOST_GCC_COMMON_CONF_OPTS += \
+       --with-long-double-128
+endif
+
 HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CROSS_PATH_SUFFIX='".br_real"'
 
 # For gcc-initial, we need to tell gcc that the C library will be
index 418d5cb387c22fefbbde9104b72e9d6319d85c5a..1c4705600ef2930158e9c274b8bd04ee1f291754 100644 (file)
@@ -46,9 +46,9 @@ config BR2_TOOLCHAIN_BUILDROOT_GLIBC
                   BR2_aarch64_be  || BR2_i386       || BR2_mips    || \
                   BR2_mipsel      || BR2_mips64     || BR2_mips64el|| \
                   BR2_powerpc     || BR2_powerpc64  || BR2_powerpc64le || \
-                  BR2_riscv       || BR2_sh         || BR2_sparc64     || \
-                  BR2_x86_64      || BR2_microblaze || BR2_nios2       || \
-                  (BR2_arc && BR2_ARC_ATOMIC_EXT)   || BR2_csky
+                  BR2_riscv       || BR2_s390x      || BR2_sh          || \
+                  BR2_sparc64     || BR2_x86_64     || BR2_microblaze  || \
+                  BR2_nios2       || (BR2_arc && BR2_ARC_ATOMIC_EXT)   || BR2_csky
        depends on BR2_USE_MMU
        depends on !BR2_STATIC_LIBS
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_2