glibc: bump version for post-2.28 fixes
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Sep 2018 13:07:13 +0000 (15:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 28 Sep 2018 13:07:30 +0000 (15:07 +0200)
Carlos O'Donell (1):
      Fix tst-setcontext9 for optimized small stacks.

DJ Delorie (3):
      RISC-V: Fix rounding save/restore bug.
      Regen RISC-V rvd ULPs
      Improve ChangeLog message.

Florian Weimer (6):
      Linux: Rewrite __old_getdents64 [BZ #23497]
      error, error_at_line: Add missing va_end calls
      nscd: Deallocate existing user names in file parser
      nss_files: Fix file stream leak in aliases lookup [BZ #23521]
      regex: Add test tst-regcomp-truncated [BZ #23578]
      misc: New test misc/tst-gethostid

H.J. Lu (1):
      i386: Use ENTRY and END in start.S [BZ #23606]

Martin Kuchta (1):
      pthread_cond_broadcast: Fix waiters-after-spinning case [BZ #23538]

Mingli Yu (1):
      Linux gethostid: Check for NULL value from gethostbyname_r [BZ #23679]

Paul Eggert (1):
      regex: fix uninitialized memory access

Samuel Thibault (2):
      hurd: Add missing symbols for proper libc_get/setspecific
      hurd: Avoid PLTs for __pthread_get/setspecific

Stefan Liebler (1):
      Fix segfault in maybe_script_execute.

Wilco Dijkstra (1):
      Fix strstr bug with huge needles (bug 23637)

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/glibc/glibc.hash
package/glibc/glibc.mk

index 096393ff9b5a611bed94bad08ba02be0779a0a35..9fff30e1ef36e43296f06f7bdd99f137214b5f73 100644 (file)
@@ -1,5 +1,5 @@
 # Locally calculated (fetched from Github)
-sha256  877c7b4741501d1762af8ef1a2518bdf2d722947d2e8d48b203e2d83cc600bca     glibc-glibc-2.28.tar.gz
+sha256  6e88cea4002efa7f78d86ea5e98eb92ed423d5a35068751517c4f00f56b8666c     glibc-glibc-2.28-18-g2339d6a55eb7a7e040ae888e906adc49eeb59eab.tar.gz
 # Locally calculated (fetched from Github)
 sha256  e08ab67b2db2d0f0e8f3311d23c54fb8f6d4c1ef6fa0b4047fd5da400e3ce9de     glibc-arc-2018.03-release.tar.gz
 
index c8ade7c28b8c2d56f2cd90b28034395eee839bc6..708c22f7234ca366244a79e58c7e487b09227c54 100644 (file)
@@ -10,7 +10,7 @@ GLIBC_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,glibc,$(GLIBC_VE
 else
 # Generate version string using:
 #   git describe --match 'glibc-*' --abbrev=40 origin/release/MAJOR.MINOR/master
-GLIBC_VERSION = glibc-2.28
+GLIBC_VERSION = glibc-2.28-18-g2339d6a55eb7a7e040ae888e906adc49eeb59eab
 # Upstream doesn't officially provide an https download link.
 # There is one (https://sourceware.org/git/glibc.git) but it's not reliable,
 # sometimes the connection times out. So use an unofficial github mirror.