u-boot: allow specification of custom Git repo as source
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 11 Jul 2011 20:46:12 +0000 (22:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 11 Jul 2011 21:41:00 +0000 (23:41 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/uboot/Config.in
boot/uboot/uboot.mk

index aada346e725446275a641c426877d7711d134068..dbd4f34dfa9db09b902b423efa47e07228112b01 100644 (file)
@@ -34,6 +34,9 @@ config BR2_TARGET_UBOOT_2010_03
 config BR2_TARGET_UBOOT_CUSTOM_TARBALL
        bool "Custom tarball"
 
+config BR2_TARGET_UBOOT_CUSTOM_GIT
+       bool "Custom Git repository"
+
 endchoice
 
 if BR2_TARGET_UBOOT_CUSTOM_TARBALL
@@ -51,6 +54,7 @@ config BR2_TARGET_UBOOT_VERSION
        default "2010.06"       if BR2_TARGET_UBOOT_2010_06
        default "2010.03"       if BR2_TARGET_UBOOT_2010_03
        default "custom"        if BR2_TARGET_UBOOT_CUSTOM_TARBALL
+       default $BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION if BR2_TARGET_UBOOT_CUSTOM_GIT
 
 config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
        string "custom patch dir"
@@ -61,6 +65,16 @@ config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
 
          Most users may leave this empty
 
+if BR2_TARGET_UBOOT_CUSTOM_GIT
+
+config BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL
+       string "URL of custom Git repository"
+
+config BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION
+       string "Custom Git version"
+
+endif
+
 choice
        prompt "U-Boot binary format"
 
index dfa012a8fcc2e57bb5f836d3748b57a2bc0e2f31..e87727b5dfac5bc22a191ecbbabf4fdd446152aa 100644 (file)
@@ -13,6 +13,9 @@ ifeq ($(UBOOT_VERSION),custom)
 UBOOT_TARBALL = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION))
 UBOOT_SITE    = $(dir $(UBOOT_TARBALL))
 UBOOT_SOURCE  = $(notdir $(UBOOT_TARBALL))
+else ifeq ($(BR2_TARGET_UBOOT_CUSTOM_GIT),y)
+UBOOT_SITE        = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL))
+UBOOT_SITE_METHOD = git
 else
 # Handle stable official U-Boot versions
 UBOOT_SITE    = ftp://ftp.denx.de/pub/u-boot