package/lua: remove 5.2.x version
authorFrancois Perrad <fperrad@gmail.com>
Sun, 2 Dec 2018 10:25:06 +0000 (11:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 9 Dec 2018 16:38:50 +0000 (17:38 +0100)
At this time :
- Lua 5.3.5 will be the last one of its serie.
- Lua 5.4 is up coming (lua-5.4.0-work2 is already available).
- Lua 5.2.4 was released on 2015.
For various reasons in the Lua ecosystem, the Lua 5.1 will stay.
On BR, Lua 5.3 is the default version since 2016.02.

So, the serie which could be removed is the 5.2.x.
We could wait some days for other user feedback.

Note: see discussion when 5.3.x was introduced :
http://lists.busybox.net/pipermail/buildroot/2015-January/117638.html

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/domoticz/Config.in
package/lrandom/lrandom.mk
package/lua/5.2.4/0001-root-path.patch [deleted file]
package/lua/5.2.4/0002-shared-libs-for-lua.patch [deleted file]
package/lua/5.2.4/0011-linenoise.patch [deleted file]
package/lua/Config.in
package/lua/lua.hash
package/lua/lua.mk
package/mpv/mpv.mk
package/wireshark/wireshark.mk

index 02321c88ae121064c6e9ea3182f46090b8e1a4ad..37119d7e58c3851fc4118950a985ffddafb77344 100644 (file)
@@ -143,6 +143,15 @@ comment "----------------------------------------------------"
 endif
 
 ###############################################################################
+comment "Legacy options removed in 2019.02"
+
+config BR2_PACKAGE_LUA_5_2
+       bool "Lua 5.2.x version removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_LUA_5_3
+       help
+         The Lua 5.2.x version was removed.
+
 comment "Legacy options removed in 2018.11"
 
 config BR2_TARGET_XLOADER
index 4c5338df0a9741367d9a1f4483433a2de644c6ea..b99e548012651daba5bb86007a1c0f23a96e6b3a 100644 (file)
@@ -8,7 +8,7 @@ config BR2_PACKAGE_DOMOTICZ
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR
-       depends on BR2_PACKAGE_LUA_5_2 || BR2_PACKAGE_LUA_5_3
+       depends on BR2_PACKAGE_LUA_5_3
        depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # exception_ptr
        select BR2_PACKAGE_BOOST
        select BR2_PACKAGE_BOOST_DATE_TIME
@@ -28,14 +28,14 @@ config BR2_PACKAGE_DOMOTICZ
 
          http://domoticz.com
 
-comment "domoticz needs lua >= 5.2 and a toolchain w/ C++, gcc >= 4.8, NPTL, wchar, dynamic library"
+comment "domoticz needs lua 5.3 and a toolchain w/ C++, gcc >= 4.8, NPTL, wchar, dynamic library"
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_INSTALL_LIBSTDCPP || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || \
                !BR2_TOOLCHAIN_HAS_THREADS_NPTL || \
                !BR2_USE_WCHAR || BR2_STATIC_LIBS || \
-               !(BR2_PACKAGE_LUA_5_2 || BR2_PACKAGE_LUA_5_3)
+               !BR2_PACKAGE_LUA_5_3
 
 comment "domoticz needs exception_ptr"
        depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
index 09b62c94a5e15d4a765da16d3fc47f528086d78a..2fe5fdb5ae10da0c62cb65b0b7192270ee69bc63 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-ifeq ($(BR2_PACKAGE_LUA_5_2)$(BR2_PACKAGE_LUA_5_3),y)
+ifeq ($(BR2_PACKAGE_LUA_5_3),y)
 LRANDOM_VERSION = 20120430.52-1
 else
 LRANDOM_VERSION = 20120430.51-1
diff --git a/package/lua/5.2.4/0001-root-path.patch b/package/lua/5.2.4/0001-root-path.patch
deleted file mode 100644 (file)
index c6f242c..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Adjust installation location to /usr.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/luaconf.h
-===================================================================
---- a/src/luaconf.h
-+++ b/src/luaconf.h
-@@ -100,7 +100,7 @@
- #else                 /* }{ */
- #define LUA_VDIR      LUA_VERSION_MAJOR "." LUA_VERSION_MINOR "/"
--#define LUA_ROOT      "/usr/local/"
-+#define LUA_ROOT      "/usr/"
- #define LUA_LDIR      LUA_ROOT "share/lua/" LUA_VDIR
- #define LUA_CDIR      LUA_ROOT "lib/lua/" LUA_VDIR
- #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.2.4/0002-shared-libs-for-lua.patch b/package/lua/5.2.4/0002-shared-libs-for-lua.patch
deleted file mode 100644 (file)
index 3cf3b24..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-Add the compilation of a shared library.
-Compile the lua binary with the shared library.
-And install the shared library.
-The variable BUILDMODE allows to switch between static and dynamic mode.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -42,6 +42,7 @@
- TO_BIN= lua luac
- TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
- TO_LIB= liblua.a
-+TO_SOLIB = liblua.so.$(R)
- TO_MAN= lua.1 luac.1
- # Lua version and release.
-@@ -60,6 +61,8 @@
- install: dummy
-       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
-       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
-+      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
-+      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
-       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
-       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
-Index: b/src/Makefile
-===================================================================
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -29,6 +29,7 @@
- PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
- LUA_A=        liblua.a
-+LUA_SO=       liblua.so
- CORE_O=       lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
-       lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
-       ltm.o lundump.o lvm.o lzio.o
-@@ -43,8 +44,13 @@
- LUAC_O=       luac.o
- ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-+ifneq (dynamic,$(BUILDMODE))
- ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
-+else
-+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
-+endif
- ALL_A= $(LUA_A)
-+ALL_SO= $(LUA_SO)
- # Targets start here.
- default: $(PLAT)
-@@ -55,12 +61,23 @@
- a:    $(ALL_A)
-+so:   $(ALL_SO)
-+
- $(LUA_A): $(BASE_O)
-       $(AR) $@ $(BASE_O)
-       $(RANLIB) $@
-+$(LUA_SO): $(CORE_O) $(LIB_O)
-+      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
-+      ln -fs $@.$(PKG_VERSION) $@
-+
-+ifneq (dynamic,$(BUILDMODE))
- $(LUA_T): $(LUA_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-+else
-+$(LUA_T): $(LUA_O) $(LUA_SO)
-+      $(CC) -o $@ -L. $(LDFLAGS) $(LUA_O) -llua $(LIBS)
-+endif
- $(LUAC_T): $(LUAC_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.2.4/0011-linenoise.patch b/package/lua/5.2.4/0011-linenoise.patch
deleted file mode 100644 (file)
index b1f228c..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Add support of linenoise (replace readline)
-
-see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/lua.c
-===================================================================
---- a/src/lua.c
-+++ b/src/lua.c
-@@ -72,6 +72,15 @@
-           add_history(lua_tostring(L, idx));  /* add it to history */
- #define lua_freeline(L,b)     ((void)L, free(b))
-+#elif defined(LUA_USE_LINENOISE)
-+
-+#include <linenoise.h>
-+#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
-+#define lua_saveline(L,idx) \
-+      if (lua_rawlen(L,idx) > 0)  /* non-empty line? */ \
-+        linenoiseHistoryAdd(lua_tostring(L, idx));  /* add it to history */
-+#define lua_freeline(L,b)     ((void)L, free(b))
-+
- #elif !defined(lua_readline)
- #define lua_readline(L,b,p) \
index 4d2f0e90fa4b93096853ac4e5357227c0a98853b..ce2e439f631691d91efc24f790429963dbb6eb78 100644 (file)
@@ -21,9 +21,6 @@ choice
 config BR2_PACKAGE_LUA_5_1
        bool "Lua 5.1.x"
 
-config BR2_PACKAGE_LUA_5_2
-       bool "Lua 5.2.x"
-
 config BR2_PACKAGE_LUA_5_3
        bool "Lua 5.3.x"
 
@@ -31,7 +28,6 @@ endchoice
 
 config BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION
        default "5.1"   if BR2_PACKAGE_LUA_5_1
-       default "5.2"   if BR2_PACKAGE_LUA_5_2
        default "5.3"   if BR2_PACKAGE_LUA_5_3
 
 if BR2_PACKAGE_LUA_5_3
index 43f5be275ec9791d7bd968b1f32bb1c26ea74f6e..ba57304d0fb1b7c729d57ba62771196f9b05d1d5 100644 (file)
@@ -2,8 +2,5 @@
 md5 4f4b4f323fd3514a68e0ab3da8ce3455           lua-5.3.5.tar.gz
 sha1 112eb10ff04d1b4c9898e121d6bdf54a81482447  lua-5.3.5.tar.gz
 
-md5 913fdb32207046b273fdb17aad70be13           lua-5.2.4.tar.gz
-sha1 ef15259421197e3d85b7d6e4871b8c26fd82c1cf  lua-5.2.4.tar.gz
-
 md5 2e115fe26e435e33b0d5c022e4490567           lua-5.1.5.tar.gz
 sha1 b3882111ad02ecc6b972f8c1241647905cb2e3fc  lua-5.1.5.tar.gz
index 22643c4c8cb9fad78c8cabed3ee1bb9bd29271fe..8a5f9258a08e0889e19cd44481f13cdf9a52e3e9 100644 (file)
@@ -7,16 +7,12 @@
 ifeq ($(BR2_PACKAGE_LUA_5_3),y)
 LUA_VERSION = 5.3.5
 else
-ifeq ($(BR2_PACKAGE_LUA_5_2),y)
-LUA_VERSION = 5.2.4
-else
 LUA_VERSION = 5.1.5
 endif
-endif
 LUA_SITE = http://www.lua.org/ftp
 LUA_INSTALL_STAGING = YES
 LUA_LICENSE = MIT
-ifeq ($(BR2_PACKAGE_LUA_5_2)$(BR2_PACKAGE_LUA_5_3),y)
+ifeq ($(BR2_PACKAGE_LUA_5_3),y)
 LUA_LICENSE_FILES = doc/readme.html
 else
 LUA_LICENSE_FILES = COPYRIGHT
@@ -26,10 +22,6 @@ LUA_PROVIDES = luainterpreter
 
 LUA_CFLAGS = -Wall -fPIC -DLUA_USE_POSIX
 
-ifeq ($(BR2_PACKAGE_LUA_5_2),y)
-LUA_CFLAGS += -DLUA_COMPAT_ALL
-endif
-
 ifeq ($(BR2_PACKAGE_LUA_5_3),y)
 LUA_CFLAGS += -DLUA_COMPAT_5_2
 endif
index b8260213b7de714571702f06cfdf83709f5b5d15..3ab26737741b1b3686ed5e0ddfc33f6d22e724bb 100644 (file)
@@ -132,7 +132,7 @@ endif
 
 # LUA support, only for lua51/lua52/luajit
 # This enables the controller (OSD) together with libass
-ifeq ($(BR2_PACKAGE_LUA_5_1)$(BR2_PACKAGE_LUA_5_2)$(BR2_PACKAGE_LUAJIT),y)
+ifeq ($(BR2_PACKAGE_LUA_5_1)$(BR2_PACKAGE_LUAJIT),y)
 MPV_CONF_OPTS += --enable-lua
 MPV_DEPENDENCIES += luainterpreter
 else
index 4720960e598c3a1a74ed1825d11ac3284d1ea032..3b83389c191039c5cba1ed08c8d5597b9eb2cbdb 100644 (file)
@@ -107,7 +107,7 @@ WIRESHARK_CONF_OPTS += --without-libxml2
 endif
 
 # no support for lua53 yet
-ifeq ($(BR2_PACKAGE_LUA_5_1)$(BR2_PACKAGE_LUA_5_2),y)
+ifeq ($(BR2_PACKAGE_LUA_5_1),y)
 WIRESHARK_CONF_OPTS += --with-lua
 WIRESHARK_DEPENDENCIES += lua
 else