package/dropbear: fix when readlink is from busybox
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 18 Aug 2015 19:25:53 +0000 (21:25 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 24 Aug 2015 15:06:06 +0000 (17:06 +0200)
Busybox "readlink -f" does not canonicalise paths when the target is
missing, while coreutils do.

Fix that by:
  - making an absolute symlink
  - dropping "-f" when calling readlink

Fixes #8276.

Reported-by: Jason Tang <tang@jtang.org>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Paul Cercueil <paul@crapouillou.net>
Cc: Alexandre Belloni <alexandre.belloni@free-electrons.com>
Tested-by: Jason Tang <tang@jtang.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dropbear/S50dropbear
package/dropbear/dropbear.mk
package/dropbear/dropbear.service

index 893878950916b2ea1f656a96df3ad23565d02266..765d6a3e1d9b547c4af1028350eb70f3875f3456 100644 (file)
@@ -18,7 +18,7 @@ start() {
        #   - the filesystem is RW (i.e. we can rm the symlink),
        #     replace the symlink with an actual directory
        if [ -L /etc/dropbear \
-            -a "$(readlink -f /etc/dropbear)" = "/var/run/dropbear" ]
+            -a "$(readlink /etc/dropbear)" = "/var/run/dropbear" ]
        then
                if rm -f /etc/dropbear; then
                        mkdir -p /etc/dropbear
index 5bbe864500837b92b6180e722d2aed1d3131ac7d..aa3fd9d928932ee620e6b1b7593309db1a67149a 100644 (file)
@@ -93,7 +93,7 @@ define DROPBEAR_INSTALL_TARGET_CMDS
        for f in $(DROPBEAR_TARGET_BINS); do \
                ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/$$f ; \
        done
-       ln -snf ../var/run/dropbear $(TARGET_DIR)/etc/dropbear
+       ln -snf /var/run/dropbear $(TARGET_DIR)/etc/dropbear
 endef
 
 $(eval $(autotools-package))
index 52c77024f5ae38c086bcded156a464856fee2949..9dcbf256cd86dcf7291987a82dfbf3ca1c2fad06 100644 (file)
@@ -10,7 +10,7 @@ After=syslog.target network.target auditd.service
 #     replace the symlink with an actual directory
 ExecStartPre=/bin/sh -c '\
 if [ -L /etc/dropbear \
-     -a "$(readlink -f /etc/dropbear)" = "/var/run/dropbear" ]; then \
+     -a "$(readlink /etc/dropbear)" = "/var/run/dropbear" ]; then \
     if rm -f /etc/dropbear; then \
         mkdir -p /etc/dropbear; \
     else \