libfuse: rename fuse to libfuse
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 Sep 2011 20:53:04 +0000 (22:53 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Sep 2011 20:42:05 +0000 (22:42 +0200)
We rename the package/fuse directory to package/libfuse to be
consistent with the package name. This is needed for a future commit
that will simplify the AUTOTARGETS macro by making assumptions on the
directory name.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/fuse/Config.in [deleted file]
package/fuse/libfuse.mk [deleted file]
package/libfuse/Config.in [new file with mode: 0644]
package/libfuse/libfuse.mk [new file with mode: 0644]

index 451b271f8d87f863ea68ff7985731d84263abb99..5d7c15dfac31a5ffec378445fa23c4773c0e8581 100644 (file)
@@ -266,7 +266,7 @@ menu "Filesystem"
 source "package/gamin/Config.in"
 source "package/libconfig/Config.in"
 source "package/libconfuse/Config.in"
-source "package/fuse/Config.in"
+source "package/libfuse/Config.in"
 source "package/liblockfile/Config.in"
 source "package/libsysfs/Config.in"
 endmenu
diff --git a/package/fuse/Config.in b/package/fuse/Config.in
deleted file mode 100644 (file)
index dffadf8..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_LIBFUSE
-       bool "libfuse"
-       depends on BR2_LARGEFILE
-       help
-         FUSE (Filesystem in UserSpacE)
-
-         http://fuse.sourceforge.net/
-
-comment "libfuse requires a toolchain with LARGEFILE support"
-        depends on !BR2_LARGEFILE
diff --git a/package/fuse/libfuse.mk b/package/fuse/libfuse.mk
deleted file mode 100644 (file)
index 86e57ff..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-#############################################################
-#
-# libfuse
-#
-#############################################################
-
-LIBFUSE_VERSION = 2.8.6
-LIBFUSE_SOURCE = fuse-$(LIBFUSE_VERSION).tar.gz
-LIBFUSE_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/fuse/
-
-LIBFUSE_INSTALL_STAGING = YES
-LIBFUSE_CONF_OPT= --disable-nls \
-               --disable-example \
-               --disable-kernel-module \
-               --enable-lib \
-               --enable-util
-
-define LIBFUSE_INSTALL_TARGET_CMDS
-       cp -dpf $(STAGING_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/bin/
-       cp -dpf $(STAGING_DIR)/usr/lib/libfuse.so* $(TARGET_DIR)/usr/lib/
-endef
-
-define LIBFUSE_CLEAN_CMDS
-       -$(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) uninstall
-       -$(MAKE) -C $(@D) clean
-       rm -f $(TARGET_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/lib/libfuse.so*
-endef
-
-$(eval $(call AUTOTARGETS,package,libfuse))
diff --git a/package/libfuse/Config.in b/package/libfuse/Config.in
new file mode 100644 (file)
index 0000000..dffadf8
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBFUSE
+       bool "libfuse"
+       depends on BR2_LARGEFILE
+       help
+         FUSE (Filesystem in UserSpacE)
+
+         http://fuse.sourceforge.net/
+
+comment "libfuse requires a toolchain with LARGEFILE support"
+        depends on !BR2_LARGEFILE
diff --git a/package/libfuse/libfuse.mk b/package/libfuse/libfuse.mk
new file mode 100644 (file)
index 0000000..86e57ff
--- /dev/null
@@ -0,0 +1,29 @@
+#############################################################
+#
+# libfuse
+#
+#############################################################
+
+LIBFUSE_VERSION = 2.8.6
+LIBFUSE_SOURCE = fuse-$(LIBFUSE_VERSION).tar.gz
+LIBFUSE_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/fuse/
+
+LIBFUSE_INSTALL_STAGING = YES
+LIBFUSE_CONF_OPT= --disable-nls \
+               --disable-example \
+               --disable-kernel-module \
+               --enable-lib \
+               --enable-util
+
+define LIBFUSE_INSTALL_TARGET_CMDS
+       cp -dpf $(STAGING_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/bin/
+       cp -dpf $(STAGING_DIR)/usr/lib/libfuse.so* $(TARGET_DIR)/usr/lib/
+endef
+
+define LIBFUSE_CLEAN_CMDS
+       -$(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) uninstall
+       -$(MAKE) -C $(@D) clean
+       rm -f $(TARGET_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/lib/libfuse.so*
+endef
+
+$(eval $(call AUTOTARGETS,package,libfuse))