valgrind: allow building on more ARM systems
authorMike Williams <mike@mikebwilliams.com>
Wed, 1 Oct 2014 15:15:49 +0000 (11:15 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Oct 2014 17:21:24 +0000 (19:21 +0200)
Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/valgrind/Config.in
package/valgrind/valgrind.mk

index fd5649b45cdbbea70e8b1835101397483d85d9b8..253555ba48eafd867791e007aa40ee1b5b4c11d2 100644 (file)
@@ -1,8 +1,9 @@
 config BR2_PACKAGE_VALGRIND
        bool "valgrind"
-       depends on BR2_i386 || BR2_x86_64 || BR2_cortex_a8 || \
-                  BR2_cortex_a9 || BR2_powerpc || BR2_mips || \
-                  BR2_mipsel || BR2_mips64 || BR2_mips64el
+       depends on BR2_i386 || BR2_x86_64 || BR2_cortex_a5 || \
+                  BR2_cortex_a7 || BR2_cortex_a8 || BR2_cortex_a9 || \
+                  BR2_cortex_a12 || BR2_cortex_a15 || BR2_powerpc || \
+                  BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el
        help
          Tool for debugging and profiling Linux programs.
 
index 24d02900a7e3d27c394a96170d1260531f2aafab..8bea03110cb7582d8ff30f5621686d2b9997a710 100644 (file)
@@ -17,7 +17,7 @@ VALGRIND_AUTORECONF = YES
 # not. Therefore, we adjust the host tuple to specify we're on
 # ARMv7. The valgrind package is guaranteed, through Config.in, to
 # only be selected on Cortex A8 and Cortex A9 platforms.
-ifeq ($(BR2_cortex_a8)$(BR2_cortex_a9),y)
+ifeq ($(BR2_cortex_a5)$(BR2_cortex_a7)$(BR2_cortex_a8)$(BR2_cortex_a9)$(BR2_cortex_a12)$(BR2_cortex_a15),y)
 VALGRIND_CONF_OPT += \
        --host=$(patsubst arm-%,armv7-%,$(GNU_TARGET_NAME))
 endif