package/luvi: fix build with aarch64
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 26 Dec 2019 08:24:47 +0000 (09:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 26 Dec 2019 08:38:54 +0000 (09:38 +0100)
aarch64 is a supported architecture of luajit since switch to moonjit
fork in commit 2ca0accc21a090874ac6e97670b47153a1f0a0b5 so manage this
new target in luvi.mk to avoid an "unknown architecture" build failure

Fixes:
 - http://autobuild.buildroot.org/results/ae610141b488d7ca8ea9db0575dec8f5eb13650c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/luvi/luvi.mk

index b6454ed32ba696b9e8f87f8d6c63249c091e4966..e311504e96ed93e5b177da11cc888a1efb5bc9b1 100644 (file)
@@ -20,6 +20,8 @@ else ifeq ($(BR2_powerpc),y)
 LUVI_TARGET_ARCH = ppc
 else ifeq ($(BR2_arm)$(BR2_armeb),y)
 LUVI_TARGET_ARCH = arm
+else ifeq ($(BR2_aarch64),y)
+LUVI_TARGET_ARCH = arm64
 else ifeq ($(BR2_mips),y)
 LUVI_TARGET_ARCH = mips
 else ifeq ($(BR2_mipsel),y)