bitstream: new package
authorJulian Scheel <julian@jusst.de>
Sun, 18 Oct 2015 12:34:10 +0000 (14:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Oct 2015 13:53:05 +0000 (15:53 +0200)
BiTStream is a set of headers to ease processing of mpeg ts
streams. It is used by dvblast.

[Thomas:
 - add missing hash file.
 - add missing BITSTREAM_LICENSE_FILES information.
 - rewrap Config.in help text.
 - use lowercase name for the package in the comment header in
   bitstream.mk.]

Signed-off-by: Julian Scheel <julian@jusst.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/bitstream/Config.in [new file with mode: 0644]
package/bitstream/bitstream.hash [new file with mode: 0644]
package/bitstream/bitstream.mk [new file with mode: 0644]

index 8e3c64a36dcde7f8b8c4ab9ca7be08397cc5c61d..c2f12f322e68e143f9caed288106069e582cf120 100644 (file)
@@ -953,6 +953,7 @@ menu "Logging"
 endmenu
 
 menu "Multimedia"
+       source "package/bitstream/Config.in"
        source "package/libass/Config.in"
        source "package/libbluray/Config.in"
        source "package/libdcadec/Config.in"
diff --git a/package/bitstream/Config.in b/package/bitstream/Config.in
new file mode 100644 (file)
index 0000000..9d967a0
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_BITSTREAM
+       bool "bitstream"
+       help
+         biTStream is a set of C headers allowing a simpler access to
+         binary structures such as specified by MPEG, DVB, IETF,
+         SMPTE, IEEE, SCTE, etc.
+
+         http://www.videolan.org/developers/bitstream.html
diff --git a/package/bitstream/bitstream.hash b/package/bitstream/bitstream.hash
new file mode 100644 (file)
index 0000000..7a3b7f8
--- /dev/null
@@ -0,0 +1,4 @@
+# from https://get.videolan.org/bitstream/1.1/bitstream-1.1.tar.bz2.md5
+md5 88e6e786242196b4d73a5b6075aeb1a2 bitstream-1.1.tar.bz2
+# locally calculated
+sha256 90b65f619895d31e652386d5d7d2d2d62cccd44383c1fac9145d659013a2de9e bitstream-1.1.tar.bz2
diff --git a/package/bitstream/bitstream.mk b/package/bitstream/bitstream.mk
new file mode 100644 (file)
index 0000000..a76c3c4
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# bitstream
+#
+################################################################################
+
+BITSTREAM_VERSION = 1.1
+BITSTREAM_SOURCE = bitstream-$(BITSTREAM_VERSION).tar.bz2
+BITSTREAM_SITE = https://get.videolan.org/bitstream/$(BITSTREAM_VERSION)
+BITSTREAM_LICENSE = MIT
+BITSTREAM_LICENSE_FILES = COPYING
+
+# package consists of header files only
+BITSTREAM_INSTALL_STAGING = YES
+BITSTREAM_INSTALL_TARGET = NO
+
+define BITSTREAM_INSTALL_STAGING_CMDS
+       $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) PREFIX=/usr install
+endef
+
+$(eval $(generic-package))