package/gdb: disable inprocess-agent in static build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 22 Feb 2019 09:50:44 +0000 (10:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 22 Feb 2019 21:29:59 +0000 (22:29 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/b40bdbca6669a81301fca523e982dbc9584a4e65

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gdb/gdb.mk

index 062f3a730c89cf704e8a1189da8e8b9eba63c857..a92696137255123e8b5a2e23e6a1542571af652a 100644 (file)
@@ -139,6 +139,11 @@ ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 GDB_CONF_OPTS += --disable-build-with-cxx
 endif
 
+# inprocess-agent can't be built statically
+ifeq ($(BR2_STATIC_LIBS),y)
+GDB_CONF_OPTS += --disable-inprocess-agent
+endif
+
 ifeq ($(BR2_PACKAGE_GDB_TUI),y)
 GDB_CONF_OPTS += --enable-tui
 else