python-iowait: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 22 Apr 2016 13:36:28 +0000 (15:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Apr 2016 22:00:04 +0000 (00:00 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-iowait/Config.in [new file with mode: 0644]
package/python-iowait/python-iowait.hash [new file with mode: 0644]
package/python-iowait/python-iowait.mk [new file with mode: 0644]

index 5103621512e69cd94edc18ecddb9aaf666b3f53a..e860f72388325a8bd8f90734b359a198173bbcbd 100644 (file)
@@ -663,6 +663,7 @@ menu "External python modules"
        source "package/python-id3/Config.in"
        source "package/python-idna/Config.in"
        source "package/python-iniparse/Config.in"
+       source "package/python-iowait/Config.in"
        source "package/python-ipaddr/Config.in"
        source "package/python-ipaddress/Config.in"
        source "package/python-ipy/Config.in"
diff --git a/package/python-iowait/Config.in b/package/python-iowait/Config.in
new file mode 100644 (file)
index 0000000..ebe96db
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_IOWAIT
+       bool "python-iowait"
+       help
+         Platform-independent module for I/O completion events.
+
+         https://launchpad.net/python-iowait
diff --git a/package/python-iowait/python-iowait.hash b/package/python-iowait/python-iowait.hash
new file mode 100644 (file)
index 0000000..67dac15
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/iowait/json
+md5    f49ca7766fe4a67e03a731e575614f87  iowait-0.2.tar.gz
+# sha256 calculated by scanpypi
+sha256 ab1bc2eb84c22ccf61f17a0024f9fb6df781b39f1852764a66a7769d5adfb299  iowait-0.2.tar.gz
diff --git a/package/python-iowait/python-iowait.mk b/package/python-iowait/python-iowait.mk
new file mode 100644 (file)
index 0000000..99c2922
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-iowait
+#
+################################################################################
+
+PYTHON_IOWAIT_VERSION = 0.2
+PYTHON_IOWAIT_SOURCE = iowait-$(PYTHON_IOWAIT_VERSION).tar.gz
+PYTHON_IOWAIT_SITE = https://pypi.python.org/packages/65/30/e953673fe9619938e9c74408401cf865f37716da89f61f6e5d9328c0f71e
+PYTHON_IOWAIT_SETUP_TYPE = distutils
+PYTHON_IOWAIT_LICENSE = LGPLv3+
+PYTHON_IOWAIT_LICENSE_FILES = COPYING.LESSER
+
+$(eval $(python-package))