target gcc: fix recompilation issue
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 10 Feb 2011 14:19:09 +0000 (11:19 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 10 Feb 2011 19:15:16 +0000 (20:15 +0100)
gcc_target wants uclibc_target which is now first stage uclibc (not
real, from the NPTL build stage addition).
This triggers gcc-final to be rebuilt (albeit cached) and reinstalled,
thus touching all the stamps around and triggering a rebuild of
gcc_target.
Switch to $(STAMP_DIR)/gcc_libs_target_installed instead so that we only
depend on the last stage of cross gcc being installed to rebuild.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/gcc/gcc-uclibc-4.x.mk

index 2c857dce59479ac0a4c3f72d6cb40b62eaca39c2..96bebd616ce95438dd521ca04c7b862ed6bf039d 100644 (file)
@@ -558,7 +558,7 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR4)/.compiled
        #rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
        touch -c $@
 
-gcc_target: uclibc_target $(GCC_TARGET_PREREQ) binutils $(TARGET_DIR)/usr/bin/gcc
+gcc_target: $(STAMP_DIR)/gcc_libs_target_installed $(GCC_TARGET_PREREQ) binutils $(TARGET_DIR)/usr/bin/gcc
 
 gcc_target-clean:
        rm -rf $(GCC_BUILD_DIR4)