package/llvm: fix build with gcc < 5.1
authorValentin Korenblit <valentinkorenblit@gmail.com>
Sat, 13 Apr 2019 08:45:55 +0000 (10:45 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 13 Apr 2019 14:51:56 +0000 (16:51 +0200)
Fixes:
http://autobuild.buildroot.net/results/0c046a1b57a4f0b992333003d41062e1b256eb0d

Signed-off-by: Valentin Korenblit <valentinkorenblit@gmail.com>
[Arnout: add explanatory comment suggested by Romain]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/llvm/llvm.mk

index cd374d74b488a9e8c38f8640bc1de0e349ff05f8..3c62285188d76b26d7d71a0407aa22f3c908d274 100644 (file)
@@ -17,6 +17,13 @@ LLVM_INSTALL_STAGING = YES
 HOST_LLVM_DEPENDENCIES = host-python
 LLVM_DEPENDENCIES = host-llvm
 
+# LLVM >= 9.0 will soon require C++14 support, building llvm 8.x using a
+# toolchain using gcc < 5.1 gives an error but actually still works. Setting
+# this option makes it still build with gcc >= 4.8.
+# https://reviews.llvm.org/D57264
+HOST_LLVM_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+LLVM_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+
 # Don't build clang libcxx libcxxabi lldb compiler-rt lld polly as llvm subprojects
 # This flag assumes that projects are checked out side-by-side and not nested
 HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_PROJECTS=""