binaries-marvell: bump version and switch to common firmware
authorSergey Matyukevich <geomatsi@gmail.com>
Sat, 21 Sep 2019 15:00:05 +0000 (18:00 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 21 Sep 2019 16:31:26 +0000 (18:31 +0200)
Since release 18.12 binaries-marvell repository provides
common firmware supporting both A7K and A8K SoC families.

This commit bumps package version to 18.12 and removes
platform specific binary selections from Config.in.
Single firmware image suitable for both A7K and A8K
platforms is now specified in mk file explicitely.

Legacy handling is not needed, as configs which did have
the option set will continue to work without change.

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
[Arnout:
 - Remove BINARIES_MARVELL_IMAGE entirely;
 - Add remark about legacy handling;
 - Remove the deprecated option from the defconfigs and test that use
   it.]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
boot/binaries-marvell/Config.in
boot/binaries-marvell/binaries-marvell.hash
boot/binaries-marvell/binaries-marvell.mk
configs/solidrun_clearfog_gt_8k_defconfig
configs/solidrun_macchiatobin_mainline_defconfig
configs/solidrun_macchiatobin_marvell_defconfig
support/testing/tests/boot/test_atf.py

index 63052070bd71035cd4c7fd63595ae614e86e92d4..80fbecb270ed4be6a5e16bf829a4517765b65c02 100644 (file)
@@ -7,26 +7,6 @@ config BR2_TARGET_BINARIES_MARVELL
          reset and system control. ATF Boot Loader stage 2 (BL2) loads
          optional SCP_BL2 image into a platform-specific region
          of secure memory. This package downloads and installs such
-         firmwares, which are needed to build ATF.
+         firmware, which is needed to build ATF.
 
          https://github.com/MarvellEmbeddedProcessors/binaries-marvell/
-
-if BR2_TARGET_BINARIES_MARVELL
-
-choice
-       prompt "Marvell Armada platform"
-
-config BR2_TARGET_BINARIES_MARVELL_7040
-       bool "7040"
-
-config BR2_TARGET_BINARIES_MARVELL_8040
-       bool "8040"
-
-endchoice
-
-config BR2_TARGET_BINARIES_MARVELL_IMAGE
-       string
-       default "mrvl_scp_bl2_mss_ap_cp1_a8040.img" if BR2_TARGET_BINARIES_MARVELL_8040
-       default "mrvl_scp_bl2_mss_ap_cp1_a7040.img" if BR2_TARGET_BINARIES_MARVELL_7040
-
-endif
index 0d214502a708a791db84d5b24a3bb3c1a17771b3..a7d5928a5da17da8b9f94be4dc8433a12d04049b 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 45c348d7a62fd147e7c6a59211a77876ce5dd26de690bd45ab79c8ff891acedf binaries-marvell-14481806e699dcc6f7025dbe3e46cf26bb787791.tar.gz
-sha256 509a36bb6faa106bbc9730c23038a361ee0c860e53a4cdf9e8605c0174fe45f7        README.md
+sha256 d818c95bcd4d5c026238d6e554151184ed7fea15bce1f861f9068b97b4cd320a binaries-marvell-c5d3ef2b63ba66d8717ecbe679fd2e639cde88ee.tar.gz
+sha256 e6d08ef60068ee72c68835001a24eb832dcba27cac0dde0f179dfb428be050ca README.md
index 6c701485407693a76500d2aeeb52a92bfedfe052..1a27fa9873c27ef881320fa6e7ff75e0bc3b3912 100644 (file)
@@ -4,18 +4,17 @@
 #
 ################################################################################
 
-# This is version binaries-marvell-armada-18.06
-BINARIES_MARVELL_VERSION = 14481806e699dcc6f7025dbe3e46cf26bb787791
+# This is version binaries-marvell-armada-18.12
+BINARIES_MARVELL_VERSION = c5d3ef2b63ba66d8717ecbe679fd2e639cde88ee
 BINARIES_MARVELL_SITE = $(call github,MarvellEmbeddedProcessors,binaries-marvell,$(BINARIES_MARVELL_VERSION))
 
 BINARIES_MARVELL_LICENSE = GPL-2.0 with freertos-exception-2.0
 BINARIES_MARVELL_LICENSE_FILES = README.md
 
-BINARIES_MARVELL_IMAGE = $(call qstrip,$(BR2_TARGET_BINARIES_MARVELL_IMAGE))
 BINARIES_MARVELL_INSTALL_IMAGES  = YES
 
 define BINARIES_MARVELL_INSTALL_IMAGES_CMDS
-       $(INSTALL) -D -m 0644 $(@D)/$(BINARIES_MARVELL_IMAGE) $(BINARIES_DIR)/scp-fw.bin
+       $(INSTALL) -D -m 0644 $(@D)/mrvl_scp_bl2.img $(BINARIES_DIR)/scp-fw.bin
 endef
 
 $(eval $(generic-package))
index a44038e663922c71cf982fa3d34aecdfc5182bfa..626302d9cd77d12e2f178b77234b10b70955240a 100644 (file)
@@ -14,7 +14,6 @@ BR2_TARGET_ARM_TRUSTED_FIRMWARE_FIP=y
 BR2_TARGET_ARM_TRUSTED_FIRMWARE_UBOOT_AS_BL33=y
 BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_VARIABLES="USE_COHERENT_MEM=0"
 BR2_TARGET_BINARIES_MARVELL=y
-BR2_TARGET_BINARIES_MARVELL_8040=y
 BR2_TARGET_MV_DDR_MARVELL=y
 
 # U-Boot
index 8e5fbfa4e8794e5f7c1027a490af458469c2276e..79eb1e05aed613cefc6e37906797d660c9545d71 100644 (file)
@@ -14,7 +14,6 @@ BR2_TARGET_ARM_TRUSTED_FIRMWARE_FIP=y
 BR2_TARGET_ARM_TRUSTED_FIRMWARE_UBOOT_AS_BL33=y
 BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_VARIABLES="USE_COHERENT_MEM=0"
 BR2_TARGET_BINARIES_MARVELL=y
-BR2_TARGET_BINARIES_MARVELL_8040=y
 BR2_TARGET_MV_DDR_MARVELL=y
 
 # U-Boot
index 4b52e479451d9a9db8fe73703de7aedc70280a8e..4d269b9f75e3d3a469192fe4f8562b20ebeb9233 100644 (file)
@@ -14,7 +14,6 @@ BR2_TARGET_ARM_TRUSTED_FIRMWARE_FIP=y
 BR2_TARGET_ARM_TRUSTED_FIRMWARE_UBOOT_AS_BL33=y
 BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_VARIABLES="USE_COHERENT_MEM=0"
 BR2_TARGET_BINARIES_MARVELL=y
-BR2_TARGET_BINARIES_MARVELL_8040=y
 BR2_TARGET_MV_DDR_MARVELL=y
 
 # U-Boot
index bb3701baedfadb9212457b87758161c20877fc74..21c3ec314e023890d9b0ed999422637cad5f9d14 100644 (file)
@@ -69,7 +69,6 @@ class TestATFMarvell(infra.basetest.BRTest):
         BR2_TARGET_ARM_TRUSTED_FIRMWARE_UBOOT_AS_BL33=y
         BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_VARIABLES="USE_COHERENT_MEM=0"
         BR2_TARGET_BINARIES_MARVELL=y
-        BR2_TARGET_BINARIES_MARVELL_8040=y
         BR2_TARGET_MV_DDR_MARVELL=y
         BR2_TARGET_UBOOT=y
         BR2_TARGET_UBOOT_BOARDNAME="mvebu_mcbin-88f8040"