bzip2: fixup build after ea448fe (convert to gentargets, add host package, bump version)
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 May 2010 13:07:05 +0000 (15:07 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 May 2010 13:07:05 +0000 (15:07 +0200)
Fix a few typos/mistakes introduced in commit ea448fe:

- bzip2 soname is not the same as package version
- It is PKG_INSTALL_STAGING, not PKG_STAGING_INSTALL
- Typo: BZIP2_INSTALL_TARGET_CMDS, not B2IP_INSTALL_TARGET_CMDS

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/bzip2/bzip2.mk

diff --git a/CHANGES b/CHANGES
index 9561a0a45de644a02f7404706bc5cc9b50a9e6f6..4aba557c2569996188daec964ee7670899081984 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -12,7 +12,7 @@
        New packages: librsync, libatomic_ops, libusb-compat, lmbench,
        netperf, squid
 
-       Updated/fixed packages: alsa-utils, busybox, directfb, dnsmasq,
+       Updated/fixed packages: alsa-utils, busybox, bzip2, directfb, dnsmasq,
        dosfstools, e2fsprogs, eeprog, fbv, freetype, haserl, hostapd,
        iperf, iptables, iw, less, libaio, libdrm, libgcrypt, libglib2,
        libpng, libxml2, libxslt, linux-fusion, lua, matchbox, mdadm,
index 43ab5f265e2a43d4d0f475410c9a9a67d8b70a8d..39e18320569de7becb00e1cbad26bcf9506e39ae 100644 (file)
@@ -4,13 +4,14 @@
 #
 #############################################################
 BZIP2_VERSION:=1.0.5
+BZIP2_SONAME=1.0.4
 BZIP2_SOURCE:=bzip2-$(BZIP2_VERSION).tar.gz
 BZIP2_SITE:=http://www.bzip.org/$(BZIP2_VERSION)
-BZIP2_STAGING_INSTALL=YES
+BZIP2_INSTALL_STAGING=YES
 
 define BZIP2_FIX_MAKEFILE
        $(SED) "s,ln \$$(,ln -snf \$$(,g" $(@D)/Makefile
-       $(SED) "s,ln -s (lib.*),ln -snf \$$1; ln -snf libbz2.so.$(BZIP2_VERSION) \
+       $(SED) "s,ln -s (lib.*),ln -snf \$$1; ln -snf libbz2.so.$(BZIP2_SONAME) \
            libbz2.so,g" $(@D)/Makefile-libbz2_so
        $(SED) "s:-O2:$(TARGET_CFLAGS):" $(@D)/Makefile
        $(SED) "s:-O2:$(TARGET_CFLAGS):" $(@D)/Makefile-libbz2_so
@@ -39,22 +40,22 @@ endef
 
 define BZIP2_INSTALL_STAGING_CMDS
        cp $(@D)/bzlib.h $(STAGING_DIR)/usr/include/
-       cp $(@D)/libbz2.so.$(BZIP2_VERSION) $(STAGING_DIR)/usr/lib/
+       cp $(@D)/libbz2.so.$(BZIP2_SONAME) $(STAGING_DIR)/usr/lib/
        cp $(@D)/libbz2.a $(STAGING_DIR)/usr/lib/
        (cd $(STAGING_DIR)/usr/lib/; \
-               ln -snf libbz2.so.$(BZIP2_VERSION) libbz2.so; \
-               ln -snf libbz2.so.$(BZIP2_VERSION) libbz2.so.1.0; \
-               ln -snf libbz2.so.$(BZIP2_VERSION) libbz2.so.1; \
+               ln -snf libbz2.so.$(BZIP2_SONAME) libbz2.so; \
+               ln -snf libbz2.so.$(BZIP2_SONAME) libbz2.so.1.0; \
+               ln -snf libbz2.so.$(BZIP2_SONAME) libbz2.so.1; \
        )
 endef
 
-define B2IP_INSTALL_TARGET_CMDS
+define BZIP2_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) \
        $(MAKE) PREFIX=$(TARGET_DIR)/usr -C $(@D) install
-       cp $(@D)/libbz2.so.$(BZIP2_VERSION) $(TARGET_DIR)/usr/lib/
+       cp $(@D)/libbz2.so.$(BZIP2_SONAME) $(TARGET_DIR)/usr/lib/
        (cd $(TARGET_DIR)/usr/lib; \
-               ln -snf libbz2.so.$(BZIP2_VERSION) libbz2.so.1.0; \
-               ln -snf libbz2.so.$(BZIP2_VERSION) libbz2.so; \
+               ln -snf libbz2.so.$(BZIP2_SONAME) libbz2.so.1.0; \
+               ln -snf libbz2.so.$(BZIP2_SONAME) libbz2.so; \
        )
        (cd $(TARGET_DIR)/usr/bin; \
                ln -snf bzip2 bunzip2; \
@@ -78,7 +79,7 @@ endef
 
 define HOST_BZIP2_FIX_MAKEFILE
        $(SED) "s,ln \$$(,ln -snf \$$(,g" $(@D)/Makefile
-       $(SED) "s,ln -s (lib.*),ln -snf \$$1; ln -snf libbz2.so.$(BZIP2_VERSION) \
+       $(SED) "s,ln -s (lib.*),ln -snf \$$1; ln -snf libbz2.so.$(BZIP2_SONAME) \
            libbz2.so,g" $(@D)/Makefile-libbz2_so
        $(SED) "s:-O2:$(HOST_CFLAGS):" $(@D)/Makefile
        $(SED) "s:-O2:$(HOST_CFLAGS):" $(@D)/Makefile-libbz2_so