grub2: force -fno-stack-protector in CFLAGS
authorErico Nunes <nunes.erico@gmail.com>
Wed, 30 Aug 2017 01:47:56 +0000 (03:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Aug 2017 20:09:21 +0000 (22:09 +0200)
grub2 fails to configure when BR2_SSP_ALL is enabled, with the following
configure error:

  checking whether -fno-asynchronous-unwind-tables works... yes
  checking whether -fno-unwind-tables works... yes
  checking for target linking format... unknown
  configure: error: no suitable link format found

This can be worked around by enforcing -fno-stack-protector in the
package CFLAGS in a way that overrides the SSP flag, as is already done
for the valgrind package.

Fixes bug #10261.

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
Reported-by: Dr I J Ormshaw <ian_ormshaw@waters.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/grub2/grub2.mk

index 36f27d14eacaed7cc43eb55a79a7a0690e5d2ec9..492cddf1a51eeb94f33604e462e5764f04305694 100644 (file)
@@ -53,7 +53,7 @@ GRUB2_CONF_ENV = \
        $(HOST_CONFIGURE_OPTS) \
        CPP="$(HOSTCC) -E" \
        TARGET_CC="$(TARGET_CC)" \
-       TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+       TARGET_CFLAGS="$(TARGET_CFLAGS) -fno-stack-protector" \
        TARGET_CPPFLAGS="$(TARGET_CPPFLAGS)" \
        TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
        NM="$(TARGET_NM)" \