libevas: disable sse3 optimizations for host builds
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 1 Feb 2012 08:18:17 +0000 (09:18 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 1 Feb 2012 08:18:17 +0000 (09:18 +0100)
There's not really any advantage to adding it, and it depends on
immintrin.h which was added in gcc 4.4, so it breaks with older
host compilers.

For details, see:

http://trac.enlightenment.org/e/ticket/942

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libevas/libevas.mk

index acb2f4bd9db53eabbe497af3ad872a019d3990b3..e34967b9c1af926d967ce7647f02ec45743530ef 100644 (file)
@@ -13,7 +13,7 @@ LIBEVAS_DEPENDENCIES = host-pkg-config zlib libeina freetype
 
 HOST_LIBEVAS_DEPENDENCIES = host-pkg-config host-zlib host-libeina \
                                host-freetype host-libpng
-HOST_LIBEVAS_CONF_OPT += --enable-image-loader-png
+HOST_LIBEVAS_CONF_OPT += --enable-image-loader-png --disable-cpu-sse3
 
 # rendering options
 ifeq ($(BR2_PACKAGE_LIBEVAS_SCALE_SAMPLE),y)