Update from .39 to .41 and change to using the muilt-binary version instead
authorManuel Novoa III <mjn3@codepoet.org>
Thu, 18 Mar 2004 06:57:20 +0000 (06:57 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Thu, 18 Mar 2004 06:57:20 +0000 (06:57 -0000)
of 3 seperate binaries.

make/dropbear_sshd.mk

index 1362aa851df687fb526438539d442608d5708d68..d694508f92a0730744b376ba78b65aa2cf2019b1 100644 (file)
@@ -3,11 +3,11 @@
 # dropbear_sshd
 #
 #############################################################
-DROPBEAR_SSHD_SOURCE:=dropbear-0.39.tar.bz2
+DROPBEAR_SSHD_SOURCE:=dropbear-0.41.tar.bz2
 DROPBEAR_SSHD_SITE:=http://matt.ucc.asn.au/dropbear/releases/
-DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.39
+DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.41
 DROPBEAR_SSHD_CAT:=bzcat
-DROPBEAR_SSHD_BINARY:=dropbear
+DROPBEAR_SSHD_BINARY:=dropbearmulti
 DROPBEAR_SSHD_TARGET_BINARY:=usr/sbin/dropbear
 
 
@@ -19,6 +19,7 @@ dropbear_sshd-source: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
 $(DROPBEAR_SSHD_DIR)/.unpacked: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
        $(DROPBEAR_SSHD_CAT) $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
        $(SOURCE_DIR)/patch-kernel.sh $(DROPBEAR_SSHD_DIR) $(SOURCE_DIR) dropbear-*.patch
+       $(SED) 's,^/\* #define DROPBEAR_MULTI.*,#define DROPBEAR_MULTI,g' $(DROPBEAR_SSHD_DIR)/options.h
        touch $(DROPBEAR_SSHD_DIR)/.unpacked
 
 $(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
@@ -46,19 +47,26 @@ $(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
        touch  $(DROPBEAR_SSHD_DIR)/.configured
 
 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY): $(DROPBEAR_SSHD_DIR)/.configured
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR)
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
+               -C $(DROPBEAR_SSHD_DIR) dropbearmulti
 
 $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY)
-       $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
-                -C $(DROPBEAR_SSHD_DIR) install
-       rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
-               $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+       #$(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
+       #       LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) install
+       #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+       #       $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+       install -d -m 755 $(TARGET_DIR)/usr/sbin
+       install -d -m 755 $(TARGET_DIR)/usr/bin
+       install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
+               $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
+       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
+       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
 
 dropbear_sshd: uclibc zlib $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
 
 dropbear_sshd-clean:
-       $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
-                -C $(DROPBEAR_SSHD_DIR) uninstall
+       $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
+               LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) uninstall
        -$(MAKE) -C $(DROPBEAR_SSHD_DIR) clean
 
 dropbear_sshd-dirclean: