gptfdisk: ensure that the package always builds/installs something
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 7 Mar 2013 10:45:25 +0000 (10:45 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Mar 2013 21:12:19 +0000 (22:12 +0100)
Until now, selecting just the gptfdisk package wouldn't do anything.
It wouldn't build anything at all, and wouldn't install anything.
This is rather odd.

So now, we ensure that at least one of the two tools that gptfdisk can
build and install is selected. This allows use to factorize a bit the
select of util-linux in Config.in, and remove the if condition in the
makefile that was preventing the package from being built if no tools
was selected.

[Peter: Reword commit text]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gptfdisk/Config.in
package/gptfdisk/gptfdisk.mk

index 7851dc3dc862726b0980e6bb90e70b582732ce25..0d7e35836e9a8bd7ce817da5c5f938fe8bef0d12 100644 (file)
@@ -3,6 +3,9 @@ config BR2_PACKAGE_GPTFDISK
        depends on BR2_LARGEFILE
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR # util-linux
+       select BR2_PACKAGE_UTIL_LINUX
+       select BR2_PACKAGE_UTIL_LINUX_LIBUUID
+       select BR2_PACKAGE_GPTFDISK_GDISK if !BR2_PACKAGE_GPTFDISK_SGDISK
        help
          GPT fdisk (consisting of the gdisk and sgdisk programs) is a
          text-mode partitioning tool that works on Globally Unique Identifier
@@ -14,8 +17,6 @@ config BR2_PACKAGE_GPTFDISK
 config BR2_PACKAGE_GPTFDISK_GDISK
        bool "interactive gdisk"
        depends on BR2_PACKAGE_GPTFDISK
-       select BR2_PACKAGE_UTIL_LINUX
-       select BR2_PACKAGE_UTIL_LINUX_LIBUUID
        help
          Install the interactive GUID partition table (GPT) manipulator
          /usr/sbin/gdisk which is modelled after and quite similar in use
@@ -24,8 +25,6 @@ config BR2_PACKAGE_GPTFDISK_GDISK
 config BR2_PACKAGE_GPTFDISK_SGDISK
        bool "command line sgdisk"
        depends on BR2_PACKAGE_GPTFDISK
-       select BR2_PACKAGE_UTIL_LINUX
-       select BR2_PACKAGE_UTIL_LINUX_LIBUUID
        select BR2_PACKAGE_POPT
        help
          Install the command-line GUID partition table (GPT) manipulator
index 7755a30c98137f8a8027c66a9b27fe976fc60e4e..2d3cb1addc2e452e200e1085c6a7f60a16d00f53 100644 (file)
@@ -10,8 +10,6 @@ GPTFDISK_SITE = http://downloads.sourceforge.net/sourceforge/gptfdisk
 GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_GDISK) += gdisk
 GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_SGDISK) += sgdisk
 
-ifneq ($(GPTFDISK_TARGETS_y),)
-
 GPTFDISK_DEPENDENCIES += util-linux
 ifeq ($(BR2_PACKAGE_GPTFDISK_SGDISK),y)
     GPTFDISK_DEPENDENCIES += popt
@@ -33,6 +31,4 @@ define GPTFDISK_UNINSTALL_TARGET_CMDS
        rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,$(GPTFDISK_TARGETS_y))
 endef
 
-endif
-
 $(eval $(generic-package))