systemd: add hook to disable ldconfig.service
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Fri, 25 Jul 2014 15:31:41 +0000 (17:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Jul 2014 07:15:23 +0000 (09:15 +0200)
Since version 215, systemd installs a service to execute /sbin/ldconfig
when the sysinit target is reached.

Unfortunately, /sbin/ldconfig is not installed on a target built using a
glibc-based toolchain.

As this service is not mandatory, it is now disabled, thus avoiding a
warning in the journal.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd.mk

index a5e1bd465e89be33aaa8f805051a55d91ea26aff..125b2fd7c4a75468aa258ee4f86e39de2ee135f5 100644 (file)
@@ -149,10 +149,17 @@ define SYSTEMD_SANITIZE_PATH_IN_UNITS
                -exec $(SED) 's,$(HOST_DIR),,g' {} \;
 endef
 
+# Disable ldconfig.service, as /sbin/ldconfig is not available when the
+# target is built with a glibc-based toolchain.
+define SYSTEMD_DISABLE_LDCONFIG_SERVICE_HOOK
+       rm -f $(TARGET_DIR)/lib/systemd/system/sysinit.target.wants/ldconfig.service
+endef
+
 SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
        SYSTEMD_INSTALL_INIT_HOOK \
        SYSTEMD_INSTALL_MACHINEID_HOOK \
        SYSTEMD_INSTALL_RESOLVCONF_HOOK \
+       SYSTEMD_DISABLE_LDCONFIG_SERVICE_HOOK \
        SYSTEMD_SANITIZE_PATH_IN_UNITS
 
 define SYSTEMD_USERS