package/systemd: check BR2_TARGET_GENERIC_GETTY
authorAndré Erdmann <dywi@mailerd.de>
Thu, 9 Oct 2014 13:58:03 +0000 (15:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 12 Oct 2014 13:43:55 +0000 (15:43 +0200)
Do not create a [serial-]getty link if BR2_TARGET_GENERIC_GETTY is not set.
Might be useful for custom setups (rootfs overlay).

[Peter: use BR2_TARGET_GENERIC_GETTY_PORT to match the code below]
Signed-off-by: André Erdmann <dywi@mailerd.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/systemd/systemd.mk

index dafc65ce21ecf0ffaa4b1ae995678931f7683e43..94407aba51eab8c5afa8dfb5b862973d561c9a83 100644 (file)
@@ -187,6 +187,7 @@ define SYSTEMD_DISABLE_SERVICE_TTY1
        rm -f $(TARGET_DIR)/etc/systemd/system/getty.target.wants/getty@tty1.service
 endef
 
+ifneq ($(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT)),)
 # systemd needs getty.service for VTs and serial-getty.service for serial ttys
 define SYSTEMD_INSTALL_SERVICE_TTY
        if echo $(BR2_TARGET_GENERIC_GETTY_PORT) | egrep -q 'tty[0-9]*$$'; \
@@ -198,6 +199,7 @@ define SYSTEMD_INSTALL_SERVICE_TTY
        ln -fs ../../../../lib/systemd/system/$${SERVICE}@.service \
                $(TARGET_DIR)/etc/systemd/system/getty.target.wants/$${SERVICE}@$(BR2_TARGET_GENERIC_GETTY_PORT).service
 endef
+endif
 
 define SYSTEMD_INSTALL_INIT_SYSTEMD
        $(SYSTEMD_DISABLE_SERVICE_TTY1)