bison: bump to version 2.4.3
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 17 Dec 2010 16:21:56 +0000 (13:21 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 22 Dec 2010 22:00:52 +0000 (23:00 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bison/Config.in
package/bison/bison-2.4.3-uclibc-sched_param-def.patch [new file with mode: 0644]
package/bison/bison.mk

index edea4f6f9df908d26678fc32796e14f966c9fecc..e8aa0b60f0ede0045af046da7e85d3bda6e9c48c 100644 (file)
@@ -1,8 +1,12 @@
 config BR2_PACKAGE_BISON
        bool "bison"
+       depends on BR2_USE_WCHAR
        help
          General-purpose parser generator that converts a
          grammar description for an LALR context-free grammar into a C
          program to parse that grammar.
 
          http://www.gnu.org/software/bison/
+
+comment "bison requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
diff --git a/package/bison/bison-2.4.3-uclibc-sched_param-def.patch b/package/bison/bison-2.4.3-uclibc-sched_param-def.patch
new file mode 100644 (file)
index 0000000..50652d8
--- /dev/null
@@ -0,0 +1,19 @@
+uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
+and is not needed too per standard. gnulib attempts to use it but we have to account
+for it because in this case uclibc does not behave like glibc.
+
+-Khem
+
+http://bugs.gentoo.org/336484
+
+--- m4-1.4.14/lib/spawn.in.h
++++ m4-1.4.14/lib/spawn.in.h
+@@ -31,7 +31,7 @@
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+    But avoid namespace pollution on glibc systems.  */
+-#ifndef __GLIBC__
++#if !defined __GLIBC__ || defined __UCLIBC__
+ # include <sched.h>
+ # include <signal.h>
+ #endif
index 9e28e85d95148c7a8074f50e96ffd459511b94a4..8849030a2826e779d5623ea21739b163c07e563b 100644 (file)
@@ -3,9 +3,9 @@
 # bison
 #
 #############################################################
-BISON_VERSION:=2.3
-BISON_SOURCE:=bison-$(BISON_VERSION).tar.bz2
-BISON_SITE:=$(BR2_GNU_MIRROR)/bison
+
+BISON_VERSION = 2.4.3
+BISON_SITE = $(BR2_GNU_MIRROR)/bison
 
 define BISON_DISABLE_EXAMPLES
        echo 'all install:' > $(@D)/examples/Makefile