alsa-lib: bump to version 1.1.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 31 Mar 2016 20:07:21 +0000 (17:07 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Apr 2016 01:57:54 +0000 (03:57 +0200)
Drop 0001-add-missing-include.patch since it's upstream.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/alsa-lib/0001-add-missing-include.patch [deleted file]
package/alsa-lib/0001-musl-pcm-h.patch [new file with mode: 0644]
package/alsa-lib/0005-musl-pcm-h.patch [deleted file]
package/alsa-lib/alsa-lib.hash
package/alsa-lib/alsa-lib.mk

diff --git a/package/alsa-lib/0001-add-missing-include.patch b/package/alsa-lib/0001-add-missing-include.patch
deleted file mode 100644 (file)
index ac7dfa9..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-Subject: [PATCH] topology: Add missing include sys/stat.h
-
-Necessary for proper definitions of S_IRUSR & co.  Otherwise it
-results in compile errors with old glibc:
-  parser.c: In function 'snd_tplg_build_file':
-  parser.c:262: error: 'S_IRUSR' undeclared (first use in this function)
-  parser.c:262: error: (Each undeclared identifier is reported only once
-  parser.c:262: error: for each function it appears in.)
-
-Signed-off-by: Takashi Iwai <tiwai@suse.de>
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
----
-Status: upstream
-
-diff --git a/src/topology/parser.c b/src/topology/parser.c
-index 80a0ae0..18bb9c7 100644
---- a/src/topology/parser.c
-+++ b/src/topology/parser.c
-@@ -16,6 +16,7 @@
-            Liam Girdwood <liam.r.girdwood@linux.intel.com>
- */
-+#include <sys/stat.h>
- #include "list.h"
- #include "tplg_local.h"
--- 
-1.7.11.7
-
diff --git a/package/alsa-lib/0001-musl-pcm-h.patch b/package/alsa-lib/0001-musl-pcm-h.patch
new file mode 100644 (file)
index 0000000..ce1528c
--- /dev/null
@@ -0,0 +1,33 @@
+Fix musl-related build errors in packages depending on alsa, in our case
+this fixes openal.
+
+Downloaded from
+http://git.alpinelinux.org/cgit/aports/tree/main/alsa-lib/alsa-lib_pcm_h.patch
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+--- alsa-lib-1.0.25/include/pcm.h
++++ alsa-lib-1.0.25.patched/include/pcm.h
+@@ -33,6 +33,7 @@
+ extern "C" {
+ #endif
++#include <stdint.h>
+ /**
+  *  \defgroup PCM PCM Interface
+  *  See the \ref pcm page for more details.
+@@ -941,10 +942,10 @@
+ int snd_pcm_format_physical_width(snd_pcm_format_t format);           /* in bits */
+ snd_pcm_format_t snd_pcm_build_linear_format(int width, int pwidth, int unsignd, int big_endian);
+ ssize_t snd_pcm_format_size(snd_pcm_format_t format, size_t samples);
+-u_int8_t snd_pcm_format_silence(snd_pcm_format_t format);
+-u_int16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
+-u_int32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
+-u_int64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
++uint8_t snd_pcm_format_silence(snd_pcm_format_t format);
++uint16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
++uint32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
++uint64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
+ int snd_pcm_format_set_silence(snd_pcm_format_t format, void *buf, unsigned int samples);
+ snd_pcm_sframes_t snd_pcm_bytes_to_frames(snd_pcm_t *pcm, ssize_t bytes);
diff --git a/package/alsa-lib/0005-musl-pcm-h.patch b/package/alsa-lib/0005-musl-pcm-h.patch
deleted file mode 100644 (file)
index ce1528c..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-Fix musl-related build errors in packages depending on alsa, in our case
-this fixes openal.
-
-Downloaded from
-http://git.alpinelinux.org/cgit/aports/tree/main/alsa-lib/alsa-lib_pcm_h.patch
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
---- alsa-lib-1.0.25/include/pcm.h
-+++ alsa-lib-1.0.25.patched/include/pcm.h
-@@ -33,6 +33,7 @@
- extern "C" {
- #endif
-+#include <stdint.h>
- /**
-  *  \defgroup PCM PCM Interface
-  *  See the \ref pcm page for more details.
-@@ -941,10 +942,10 @@
- int snd_pcm_format_physical_width(snd_pcm_format_t format);           /* in bits */
- snd_pcm_format_t snd_pcm_build_linear_format(int width, int pwidth, int unsignd, int big_endian);
- ssize_t snd_pcm_format_size(snd_pcm_format_t format, size_t samples);
--u_int8_t snd_pcm_format_silence(snd_pcm_format_t format);
--u_int16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
--u_int32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
--u_int64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
-+uint8_t snd_pcm_format_silence(snd_pcm_format_t format);
-+uint16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
-+uint32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
-+uint64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
- int snd_pcm_format_set_silence(snd_pcm_format_t format, void *buf, unsigned int samples);
- snd_pcm_sframes_t snd_pcm_bytes_to_frames(snd_pcm_t *pcm, ssize_t bytes);
index 506416d2af937c70b481789166a7673ac6cbb415..49be64392d05d59b16bf21c633b2a6c9807100b1 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15        alsa-lib-1.1.0.tar.bz2
+sha256 8ac76c3144ed2ed49da7622ab65ac5415205913ccbedde877972383cbc234269        alsa-lib-1.1.1.tar.bz2
index 2075d419dbaa7c87184d1cd4fe79bb41c1cfda2f..ae0377db3ed0de8bd7920887ce88967b7da1fa9b 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-ALSA_LIB_VERSION = 1.1.0
+ALSA_LIB_VERSION = 1.1.1
 ALSA_LIB_SOURCE = alsa-lib-$(ALSA_LIB_VERSION).tar.bz2
 ALSA_LIB_SITE = ftp://ftp.alsa-project.org/pub/lib
 ALSA_LIB_LICENSE = LGPLv2.1+