python-priority: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 5 Jul 2017 13:47:42 +0000 (15:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 31 Jul 2017 19:31:35 +0000 (21:31 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-priority/Config.in [new file with mode: 0644]
package/python-priority/python-priority.hash [new file with mode: 0644]
package/python-priority/python-priority.mk [new file with mode: 0644]

index d595e88b1265982c3b2a4b8bbfc4a96b85e9f57f..86d714dae47a7eac55c2e177262c0adb320171ba 100644 (file)
@@ -797,6 +797,7 @@ menu "External python modules"
        source "package/python-pillow/Config.in"
        source "package/python-portend/Config.in"
        source "package/python-posix-ipc/Config.in"
+       source "package/python-priority/Config.in"
        source "package/python-prompt-toolkit/Config.in"
        source "package/python-protobuf/Config.in"
        source "package/python-psutil/Config.in"
diff --git a/package/python-priority/Config.in b/package/python-priority/Config.in
new file mode 100644 (file)
index 0000000..b73b7e2
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_PRIORITY
+       bool "python-priority"
+       help
+         A pure-Python implementation of the HTTP/2 priority tree.
+
+         http://python-hyper.org/priority/
diff --git a/package/python-priority/python-priority.hash b/package/python-priority/python-priority.hash
new file mode 100644 (file)
index 0000000..e115d6a
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/priority/json, sha256 locally computed
+md5    4f1ff52f7fa448e9d9cb46337ae86d1e  priority-1.3.0.tar.gz
+sha256 6bc1961a6d7fcacbfc337769f1a382c8e746566aaa365e78047abe9f66b2ffbe  priority-1.3.0.tar.gz
diff --git a/package/python-priority/python-priority.mk b/package/python-priority/python-priority.mk
new file mode 100644 (file)
index 0000000..8b6dbc1
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-priority
+#
+################################################################################
+
+PYTHON_PRIORITY_VERSION = 1.3.0
+PYTHON_PRIORITY_SOURCE = priority-$(PYTHON_PRIORITY_VERSION).tar.gz
+PYTHON_PRIORITY_SITE = https://pypi.python.org/packages/ba/96/7d0b024087062418dfe02a68cd6b195399266ac002fb517aad94cc93e076
+PYTHON_PRIORITY_SETUP_TYPE = setuptools
+PYTHON_PRIORITY_LICENSE = MIT
+PYTHON_PRIORITY_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))