package/kodi: Add suboption to control unrar support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 11 Jul 2016 18:08:58 +0000 (20:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Jul 2016 12:29:01 +0000 (14:29 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: tweak Config.in description.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index a000e79a0b3a25b9bd5ad75512b1df68a97c5182..a4cbab2da7aa0e4fc1d3eed36c2ee61e3c100537 100644 (file)
@@ -174,6 +174,12 @@ config BR2_PACKAGE_KODI_LIBNFS
 comment "nfs support needs a toolchain w/ threads support"
        depends on !(BR2_TOOLCHAIN_HAS_THREADS || BR2_TOOLCHAIN_HAS_NATIVE_RPC)
 
+config BR2_PACKAGE_KODI_NONFREE
+       bool "nonfree components"
+       help
+         Enable components with non-free licenses. This option
+         currently only controls support for RAR archives.
+
 config BR2_PACKAGE_KODI_RTMPDUMP
        bool "rtmp"
        select BR2_PACKAGE_RTMPDUMP
index 52593aa595d18ab73a423c44f6875b5477cf4d8f..da5d1fa75a1969b408c585335d373085555e2c74 100644 (file)
@@ -86,6 +86,14 @@ else
 KODI_CONF_OPTS += --disable-mysql
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_NONFREE),y)
+KODI_CONF_OPTS += --enable-non-free
+KODI_LICENSE := $(KODI_LICENSE), unrar
+KODI_LICENSE_FILES += lib/UnrarXLib/license.txt
+else
+KODI_CONF_OPTS += --disable-non-free
+endif
+
 ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 KODI_DEPENDENCIES += rpi-userland
 KODI_CONF_OPTS += --with-platform=raspberry-pi --enable-player=omxplayer