package/perl-libwww-perl: Move package/perl-libwww to new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 25 Apr 2015 13:14:02 +0000 (15:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Apr 2015 14:46:29 +0000 (16:46 +0200)
This move is necessary to sync the package with scancpan output
as suggested by Francois.
http://lists.busybox.net/pipermail/buildroot/2015-April/126406.html

Since perl-libwww was never part of any official buildroot release
I did not bother the include legavy handling of its options ;)

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-libwww-perl/Config.in [new file with mode: 0644]
package/perl-libwww-perl/perl-libwww-perl.hash [new file with mode: 0644]
package/perl-libwww-perl/perl-libwww-perl.mk [new file with mode: 0644]
package/perl-libwww/Config.in [deleted file]
package/perl-libwww/perl-libwww.mk [deleted file]

index 3370d59139cee61dc299e79139c020eb39edcc03..6f73c825d0ad7dad05e6409f3767d95eeeb12e19 100644 (file)
@@ -523,7 +523,7 @@ menu "Perl libraries/modules"
        source "package/perl-io-html/Config.in"
        source "package/perl-io-socket-ssl/Config.in"
        source "package/perl-json-tiny/Config.in"
-       source "package/perl-libwww/Config.in"
+       source "package/perl-libwww-perl/Config.in"
        source "package/perl-lwp-mediatypes/Config.in"
        source "package/perl-mail-dkim/Config.in"
        source "package/perl-mailtools/Config.in"
diff --git a/package/perl-libwww-perl/Config.in b/package/perl-libwww-perl/Config.in
new file mode 100644 (file)
index 0000000..3db0070
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_PERL_LIBWWW_PERL
+       bool "perl-libwww-perl"
+       select BR2_PACKAGE_PERL_ENCODE_LOCALE
+       select BR2_PACKAGE_PERL_FILE_LISTING
+       select BR2_PACKAGE_PERL_HTML_PARSER
+       select BR2_PACKAGE_PERL_HTTP_COOKIES
+       select BR2_PACKAGE_PERL_HTTP_DAEMON
+       select BR2_PACKAGE_PERL_HTTP_DATE
+       select BR2_PACKAGE_PERL_HTTP_MESSAGE
+       select BR2_PACKAGE_PERL_HTTP_NEGOTIATE
+       select BR2_PACKAGE_PERL_LWP_MEDIATYPES
+       select BR2_PACKAGE_PERL_NET_HTTP
+       select BR2_PACKAGE_PERL_URI
+       select BR2_PACKAGE_PERL_WWW_ROBOTRULES
+       help
+         The World-Wide Web library for Perl
+
+         https://metacpan.org/release/libwww-perl
diff --git a/package/perl-libwww-perl/perl-libwww-perl.hash b/package/perl-libwww-perl/perl-libwww-perl.hash
new file mode 100644 (file)
index 0000000..1ef5ccf
--- /dev/null
@@ -0,0 +1,3 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    85b36bcd2fd2450718ee14f894f0d3d1 libwww-perl-6.13.tar.gz
+sha256 5fbd13eebd1933e5a203fceb2c1629efbccff3efc8fab6ec0285c79d0a95f8b2 libwww-perl-6.13.tar.gz
diff --git a/package/perl-libwww-perl/perl-libwww-perl.mk b/package/perl-libwww-perl/perl-libwww-perl.mk
new file mode 100644 (file)
index 0000000..64cbfd4
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# perl-libwww-perl
+#
+################################################################################
+
+PERL_LIBWWW_PERL_VERSION = 6.13
+PERL_LIBWWW_PERL_SOURCE = libwww-perl-$(PERL_LIBWWW_PERL_VERSION).tar.gz
+PERL_LIBWWW_PERL_SITE = $(BR2_CPAN_MIRROR)/authors/id/E/ET/ETHER
+PERL_LIBWWW_PERL_LICENSE = Artistic or GPLv1+
+PERL_LIBWWW_LICENSE_FILES = README
+PERL_LIBWWW_PERL_DEPENDENCIES = \
+       perl \
+       perl-encode-locale \
+       perl-file-listing \
+       perl-html-parser \
+       perl-http-cookies \
+       perl-http-daemon \
+       perl-http-date \
+       perl-http-message \
+       perl-http-negotiate \
+       perl-lwp-mediatypes \
+       perl-net-http \
+       perl-uri \
+       perl-www-robotrules
+
+$(eval $(perl-package))
diff --git a/package/perl-libwww/Config.in b/package/perl-libwww/Config.in
deleted file mode 100644 (file)
index 523371f..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-config BR2_PACKAGE_PERL_LIBWWW
-       bool "perl-libwww"
-       select BR2_PACKAGE_PERL_ENCODE_LOCALE
-       select BR2_PACKAGE_PERL_FILE_LISTING
-       select BR2_PACKAGE_PERL_HTML_PARSER
-       select BR2_PACKAGE_PERL_HTTP_COOKIES
-       select BR2_PACKAGE_PERL_HTTP_DAEMON
-       select BR2_PACKAGE_PERL_HTTP_NEGOTIATE
-       select BR2_PACKAGE_PERL_LWP_MEDIATYPES
-       select BR2_PACKAGE_PERL_NET_HTTP
-       select BR2_PACKAGE_PERL_URI
-       select BR2_PACKAGE_PERL_WWW_ROBOTRULES
-       help
-         The World-Wide Web library for Perl
-
-         https://github.com/libwww-perl/libwww-perl
diff --git a/package/perl-libwww/perl-libwww.mk b/package/perl-libwww/perl-libwww.mk
deleted file mode 100644 (file)
index 8157be2..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-################################################################################
-#
-# perl-libwww
-#
-################################################################################
-
-PERL_LIBWWW_VERSION = 6.13
-PERL_LIBWWW_SITE = $(call github,libwww-perl,libwww-perl,$(PERL_LIBWWW_VERSION))
-PERL_LIBWWW_LICENSE = Artistic or GPLv1+
-PERL_LIBWWW_LICENSE_FILES = README
-PERL_LIBWWW_DEPENDENCIES = \
-       perl-encode-locale \
-       perl-file-listing \
-       perl-html-parser \
-       perl-http-cookies \
-       perl-http-daemon \
-       perl-http-date \
-       perl-http-negotiate \
-       perl-net-http \
-       perl-uri \
-       perl-www-robotrules
-
-$(eval $(perl-package))