kismet: fix build when none of client, server or drone are selected
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Aug 2010 17:38:04 +0000 (19:38 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Aug 2010 09:08:32 +0000 (11:08 +0200)
Random package configuration can trigger the selection of kismet, but
neither of client, server or drone suboptions. In this case, the
KISMET_TARGET_BINARIES variable is empty, leading to failure during
the installation stage.

At the same time, we remove the useless stripping of the installed
binaries, since this is done globally by the Buildroot infrastructure.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
CHANGES
package/kismet/kismet.mk

diff --git a/CHANGES b/CHANGES
index 3cc717104b1b44905fb1a33e12478514db9102f2..1cc9a387c58178abf7ab58826b3535794eeecd4c 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        fs: old-style squashfs for big endian archs fixed.
 
        Updated/fixed packages: busybox, gst-plugins-base,
-       imagemagick, libgail, libglib2, libgtk2, lua, luafilesystem,
-       lzo, ncurses, netcat, pango, php, pppd, proftpd, qt, samba,
-       startup-notification, swfdec, sysvinit, util-linux
+       imagemagick, kismet, libgail, libglib2, libgtk2, lua,
+       luafilesystem, lzo, ncurses, netcat, pango, php, pppd,
+       proftpd, qt, samba, startup-notification, swfdec, sysvinit,
+       util-linux
 
        Removed packages: stunnel
 
index 1b61ddda35ce8a09d225263fd0afa67e13fbd987..6135c88731fe49e5b45d18ee601af3b20cacace9 100644 (file)
@@ -33,18 +33,19 @@ $(eval $(call AUTOTARGETS,package,kismet))
 
 $(KISMET_TARGET_INSTALL_TARGET):
        $(call MESSAGE,"Installing")
+ifdef KISMET_TARGET_BINARIES
        $(INSTALL) -m 755 $(addprefix $(KISMET_DIR)/, $(KISMET_TARGET_BINARIES)) $(TARGET_DIR)/usr/bin
+endif
 ifdef KISMET_TARGET_CONFIGS
        $(INSTALL) -m 644 $(addprefix $(KISMET_DIR)/conf/, $(KISMET_TARGET_CONFIGS)) $(TARGET_DIR)/etc
-endif
-ifeq ($(BR2_ENABLE_DEBUG),)
-       $(STRIPCMD) $(STRIP_STRIP_ALL) $(addprefix $(TARGET_DIR)/usr/bin/, $(KISMET_TARGET_BINARIES))
 endif
        touch $@
 
 $(KISMET_TARGET_UNINSTALL):
        $(call MESSAGE,"Uninstalling")
+ifdef KISMET_TARGET_BINARIES
        rm -f $(addprefix $(TARGET_DIR)/usr/bin/, $(KISMET_TARGET_BINARIES))
+endif
 ifdef KISMET_TARGET_CONFIGS
        rm -f $(addprefix $(TARGET_DIR)/etc/, $(KISMET_TARGET_CONFIGS))
 endif