package/xserver_xorg-server: make the version a choice
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 21 Apr 2015 17:04:38 +0000 (19:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Apr 2015 20:24:10 +0000 (22:24 +0200)
Only a single entry for now, but we'll add one more in an upcoming
patch, to support old binary-only drivers, like the NVidia Tegra2/3
drivers.

[Thomas:
 - rename option from BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_17_1 to
   BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_17, since we don't want to
   rename the option at each minor release of the X.org server, and
   X.org servers with the same major version will not have a different
   ABI.]

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index 1123f3b7401532daef6863110c8891b363922b1d..48ccf514da7c975c855bf0f9f7f626d1d6a18919 100644 (file)
@@ -56,6 +56,18 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
 
 if BR2_PACKAGE_XSERVER_XORG_SERVER
 
+choice
+       bool "X Window System server version"
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_17
+       bool "1.17.1"
+
+endchoice
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_VERSION
+       string
+       default "1.17.1" if BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_17
+
 choice
        prompt "X Window System server type"
        default BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE
index f120becce2922a031856fac45b6417bf98c5f917..d08197de13c8f603ed8559435522cb47a14ed08d 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-XSERVER_XORG_SERVER_VERSION = 1.17.1
+XSERVER_XORG_SERVER_VERSION = $(call qstrip,$(BR2_PACKAGE_XSERVER_XORG_SERVER_VERSION))
 XSERVER_XORG_SERVER_SOURCE = xorg-server-$(XSERVER_XORG_SERVER_VERSION).tar.bz2
 XSERVER_XORG_SERVER_SITE = http://xorg.freedesktop.org/releases/individual/xserver
 XSERVER_XORG_SERVER_LICENSE = MIT