Makefile: save MAKE_VERSION
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 14 Jul 2015 21:30:39 +0000 (18:30 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 21:53:21 +0000 (23:53 +0200)
Save MAKE_VERSION as RUNNING_MAKE_VERSION since this is later clobbered
by the make package.

It will be used by the webkitgtk24 package to check for older make
versions which have a bug building it with parallel jobs (it hangs).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 9a18853114dee33f1fb377cba4225ceedc50b4dc..531ac5dc388985a19fe5212015815368173f16a8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -43,10 +43,13 @@ all:
 # Set and export the version string
 export BR2_VERSION := 2015.08-git
 
+# Save running make version since it's clobbered by the make package
+RUNNING_MAKE_VERSION := $(MAKE_VERSION)
+
 # Check for minimal make version (note: this check will break at make 10.x)
 MIN_MAKE_VERSION = 3.81
-ifneq ($(firstword $(sort $(MAKE_VERSION) $(MIN_MAKE_VERSION))),$(MIN_MAKE_VERSION))
-$(error You have make '$(MAKE_VERSION)' installed. GNU make >= $(MIN_MAKE_VERSION) is required)
+ifneq ($(firstword $(sort $(RUNNING_MAKE_VERSION) $(MIN_MAKE_VERSION))),$(MIN_MAKE_VERSION))
+$(error You have make '$(RUNNING_MAKE_VERSION)' installed. GNU make >= $(MIN_MAKE_VERSION) is required)
 endif
 
 export HOSTARCH := $(shell uname -m | \