package/libglib2: fix util-linux dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Nov 2020 10:23:26 +0000 (11:23 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 1 Nov 2020 10:35:25 +0000 (11:35 +0100)
Replace util-linux dependency by util-linux-libs to break the following
circular dependency:

 util-linux -> udev -> systemd -> polkit -> libglib2 -> util-linux

which will result in the following build failure:

../output-1/build/libglib2-2.64.4/meson.build:1931:2: ERROR: Dependency "mount" not found, tried pkgconfig

This will also raise the following build failure with util-linux:

checking for udev_new in -ludev... no
configure: error: udev selected but libudev not found

Fixes:
 - http://autobuild.buildroot.org/results/d2da9bda4e38b301d11d3baa66ea171e9e087171
 - http://autobuild.buildroot.org/results/520e9f18015fe26f93eb26387524766440e63f23

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libglib2/libglib2.mk

index fda04334f54937876d79344d74e375533f961315..43fcb27faea70d1196c023d5a8f2c93f4430f4bd 100644 (file)
@@ -86,7 +86,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBMOUNT),y)
 LIBGLIB2_CONF_OPTS += -Dlibmount=enabled
-LIBGLIB2_DEPENDENCIES += util-linux
+LIBGLIB2_DEPENDENCIES += util-linux-libs
 else
 LIBGLIB2_CONF_OPTS += -Dlibmount=disabled
 endif