package/janus-gateway: bump to version 0.10.1
authorAdam Duskett <Aduskett@gmail.com>
Sun, 14 Jun 2020 21:19:12 +0000 (14:19 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 18 Jun 2020 20:14:19 +0000 (22:14 +0200)
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/janus-gateway/0002-Add-test-for-Wunused-but-set-variable.patch
package/janus-gateway/janus-gateway.hash
package/janus-gateway/janus-gateway.mk

index ac6b04507863ebc2bf2e052db40ffbcfef070361..c68d6b3b024e232dfb5cc4167e98066b6ec6575c 100644 (file)
@@ -26,12 +26,12 @@ Signed-off-by: Adam Duskett <Aduskett@gmail.com>
  create mode 100644 m4/ax_check_compile_flag.m4
 
 diff --git a/Makefile.am b/Makefile.am
-index c6e9ad2..42d256b 100644
+index f961fdb..3ddbe59 100644
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -140,6 +140,7 @@ janus_CFLAGS = \
-       -DTRANSPORTDIR=\"$(transportdir)\" \
+@@ -151,6 +151,7 @@ janus_CFLAGS = \
        -DEVENTDIR=\"$(eventdir)\" \
+       -DLOGGERDIR=\"$(loggerdir)\" \
        -DCONFDIR=\"$(confdir)\" \
 +      @GCC_WARN_UNUSED_BUT_SET@ \
        $(BORINGSSL_CFLAGS) \
@@ -60,7 +60,7 @@ index ca17a29..beef91a 100644
 +              -Wunsafe-loop-optimizations"
  esac
  
- JANUS_VERSION=63
+ JANUS_VERSION=101
 diff --git a/m4/ax_check_compile_flag.m4 b/m4/ax_check_compile_flag.m4
 new file mode 100644
 index 0000000..51df0c0
index c61ffcd5b654bcdd564fa15156aed54fd6eab479..64af9195190e884e7e5de41cf35d0decf9e126af 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256 b6829edaf25862fbf613e2c3d2be7cad29943c0bb1ea5d1b935a07abfee37245 janus-gateway-0.9.2.tar.gz
-sha256 91d04c97fa1da3fcd28205873276358aafc071c5b00a9ea8c49dd06d487a9dc6 COPYING
+sha256  731760e6911908bc523815809487e51320a738f3533f267d4beb83eaa725de85  janus-gateway-0.10.1.tar.gz
+sha256  91d04c97fa1da3fcd28205873276358aafc071c5b00a9ea8c49dd06d487a9dc6  COPYING
index bbc7f95ee160ec788919a023c6504f37b9aa5917..0ecd83fce1429e8d06e7526f7d68e6a9fe90aae5 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-JANUS_GATEWAY_VERSION = 0.9.2
+JANUS_GATEWAY_VERSION = 0.10.1
 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,v$(JANUS_GATEWAY_VERSION))
 JANUS_GATEWAY_LICENSE = GPL-3.0 with OpenSSL exception
 JANUS_GATEWAY_LICENSE_FILES = COPYING