fs: declare phony targets as such
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Apr 2015 16:37:46 +0000 (18:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Apr 2015 08:12:32 +0000 (10:12 +0200)
This commit improves the filesystem handling code to declare its
various targets as PHONY when appropriate.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
fs/common.mk
fs/ext2/ext2.mk
fs/initramfs/initramfs.mk
fs/iso9660/iso9660.mk

index 5d07f0056110b0cb09565fec82c2134b89b9a63e..cac127feec6d315936a16e25969186e5638664a3 100644 (file)
@@ -102,6 +102,8 @@ rootfs-$(1)-show-depends:
 
 rootfs-$(1): $$(BINARIES_DIR)/rootfs.$(1) $$(ROOTFS_$(2)_POST_TARGETS)
 
+.PHONY: rootfs-$(1) rootfs-$(1)-show-depends
+
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)),y)
 TARGETS_ROOTFS += rootfs-$(1)
 endif
index 1cac72e0d570ec44701fe6e16f2a5e983c1d7a3a..cab66a5e2458cd231c9b6519a1f3b325d084eeb2 100644 (file)
@@ -35,6 +35,8 @@ endef
 rootfs-ext2-symlink:
        ln -sf rootfs.ext2$(ROOTFS_EXT2_COMPRESS_EXT) $(BINARIES_DIR)/rootfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN)$(ROOTFS_EXT2_COMPRESS_EXT)
 
+.PHONY: rootfs-ext2-symlink
+
 ifneq ($(BR2_TARGET_ROOTFS_EXT2_GEN),2)
 ROOTFS_EXT2_POST_TARGETS += rootfs-ext2-symlink
 endif
index 308924d57409a00acf26a4ee91bf888909868221..db5081224cf2dfd71a7766ee3e27362c515d03ee 100644 (file)
@@ -17,6 +17,8 @@ rootfs-initramfs: $(ROOTFS_INITRAMFS_DEPENDENCIES) $(ROOTFS_INITRAMFS_POST_TARGE
 rootfs-initramfs-show-depends:
        @echo $(ROOTFS_INITRAMFS_DEPENDENCIES)
 
+.PHONY: rootfs-initramfs rootfs-initramfs-show-depends
+
 ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
 TARGETS_ROOTFS += rootfs-initramfs
 endif
index 5b44ba42413c3079506e44ebfe5457be2a5f723d..4ccfce955cdf0af1f1c8b5db15be6bec0e90e682 100644 (file)
@@ -48,6 +48,8 @@ rootfs-iso9660: $(BINARIES_DIR)/rootfs.iso9660
 rootfs-iso9660-show-depends:
        @echo $(ROOTFS_ISO9660_DEPENDENCIES)
 
+.PHONY: rootfs-iso9660 rootfs-iso9660-show-depends
+
 ################################################################################
 #
 # Toplevel Makefile options