linux/perf: forcefully disable the features with missing dependencies
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 11 Mar 2016 18:19:56 +0000 (19:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Mar 2016 13:38:06 +0000 (14:38 +0100)
Forcefully disable the features that have optional dependencies that are
not enabled in Buildroot.

Disable support for bionic since, well, we're not Android.

Slightly re-order the variables to have semantically-related variables
together, with features last.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux-tool-perf.mk

index a5fbf2197cb8b66128937cb40096e8feae30f3b2..d4b8f0ef60530fef8c99d6bf2346a766799db560 100644 (file)
@@ -18,14 +18,15 @@ PERF_MAKE_FLAGS = \
        $(LINUX_MAKE_FLAGS) \
        JOBS=$(PARALLEL_JOBS) \
        ARCH=$(PERF_ARCH) \
+       DESTDIR=$(TARGET_DIR) \
+       prefix=/usr \
+       WERROR=0 \
        NO_LIBAUDIT=1 \
        NO_NEWT=1 \
        NO_GTK2=1 \
        NO_LIBPERL=1 \
        NO_LIBPYTHON=1 \
-       DESTDIR=$(TARGET_DIR) \
-       prefix=/usr \
-       WERROR=0
+       NO_LIBBIONIC=1
 
 # We need to pass an argument to ld for setting the endianness when
 # building it for MIPS architecture, otherwise the default one will
@@ -52,14 +53,20 @@ endif
 
 ifeq ($(BR2_PACKAGE_SLANG),y)
 PERF_DEPENDENCIES += slang
+else
+PERF_MAKE_FLAGS += NO_SLANG=1
 endif
 
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 PERF_DEPENDENCIES += libunwind
+else
+PERF_MAKE_FLAGS += NO_LIBUNWIND=1
 endif
 
 ifeq ($(BR2_PACKAGE_NUMACTL),y)
 PERF_DEPENDENCIES += numactl
+else
+PERF_MAKE_FLAGS += NO_LIBNUMA=1
 endif
 
 ifeq ($(BR2_PACKAGE_ELFUTILS),y)