libroxml: fix avr32 build failure
authorSimon Dawson <spdawson@gmail.com>
Thu, 21 Nov 2013 17:19:40 +0000 (17:19 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 22 Nov 2013 11:19:57 +0000 (12:19 +0100)
The -Wno-unused-result option is not understood by the version of gcc used by the
avr32 toolchain. Remove the option from the compilation flags.

Fixes build failures such as the following.

  http://autobuild.buildroot.net/results/e22/e22d94fca3eabb4e54d82af04319f17ad8e10c20/

The single existing patch for libroxml has been renamed to include a numerical
component for application order sorting. The existing patch has also been updated
to apply without fuzz.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libroxml/libroxml-0001-werror.patch [new file with mode: 0644]
package/libroxml/libroxml-0002-wno-unused-result.patch [new file with mode: 0644]
package/libroxml/libroxml-werror.patch [deleted file]

diff --git a/package/libroxml/libroxml-0001-werror.patch b/package/libroxml/libroxml-0001-werror.patch
new file mode 100644 (file)
index 0000000..91f322c
--- /dev/null
@@ -0,0 +1,22 @@
+[PATCH] remove -Werror from CFLAGS
+
+-Werror should only be used during development, not in released SW.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: a/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -46,7 +46,7 @@
+ # options
+ override CPPFLAGS += -Iinc/
+-override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Werror -Iinc/ $(DEFINES)
++override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Iinc/ $(DEFINES)
+ override LDFLAGS += 
+ ifeq ("$(OS)", "Darwin")
diff --git a/package/libroxml/libroxml-0002-wno-unused-result.patch b/package/libroxml/libroxml-0002-wno-unused-result.patch
new file mode 100644 (file)
index 0000000..406bf3c
--- /dev/null
@@ -0,0 +1,21 @@
+The -Wno-unused-result option is not understood by the version of gcc used by the
+avr32 toolchain. Remove the option from the compilation flags.
+
+Fixes build failures such as the following.
+
+  http://autobuild.buildroot.net/results/e22/e22d94fca3eabb4e54d82af04319f17ad8e10c20/
+
+Signed-off-by: Simon Dawson <spdawson@gmail.com>
+
+diff -Nurp a/Makefile b/Makefile
+--- a/Makefile 2013-11-21 17:13:17.679388374 +0000
++++ b/Makefile 2013-11-21 17:13:35.219299157 +0000
+@@ -46,7 +46,7 @@ DEFINES = -DIGNORE_EMPTY_TEXT_NODES
+ # options
+ override CPPFLAGS += -Iinc/
+-override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Iinc/ $(DEFINES)
++override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Iinc/ $(DEFINES)
+ override LDFLAGS += 
+ ifeq ("$(OS)", "Darwin")
diff --git a/package/libroxml/libroxml-werror.patch b/package/libroxml/libroxml-werror.patch
deleted file mode 100644 (file)
index 6435b01..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-[PATCH] remove -Werror from CFLAGS
-
--Werror should only be used during development, not in released SW.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- Makefile |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: a/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -41,7 +41,7 @@
- # options
- override CPPFLAGS += -Iinc/
--override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Werror -Iinc/ $(DEFINES)
-+override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Iinc/ $(DEFINES)
- override LDFLAGS += 
- ifeq ("$(OS)", "Darwin")