fs: add option to define path to custom rootfs skeleton
authorDmytro Milinevskyy <milinevskyy@gmail.com>
Wed, 16 Jun 2010 20:25:56 +0000 (23:25 +0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 18 Jul 2010 21:15:55 +0000 (23:15 +0200)
Signed-off-by: Dmytro Milinevskyy <milinevskyy@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
fs/Config.in

index 59151cc2f0cb672f9a95d569306a5946b6b3333d..744cae44526613a85e5d0429cc27cff89252ffb2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -367,6 +367,10 @@ $(STAGING_DIR):
        @mkdir -p $(STAGING_DIR)/usr/include
        @mkdir -p $(STAGING_DIR)/usr/bin
 
+ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
+TARGET_SKELETON=$(BR2_ROOTFS_SKELETON_CUSTOM_PATH)
+endif
+
 $(BUILD_DIR)/.root:
        mkdir -p $(TARGET_DIR)
        if ! [ -d "$(TARGET_DIR)/bin" ]; then \
index 6865eeaff78f1e0c2cba0352c2d6135e26900250..188e8155be865fd42d21404934cb2d1193aa2183 100644 (file)
@@ -23,6 +23,29 @@ config BR2_ROOTFS_DEVICE_TABLE
          to the makedevs utility to create all the special device
          files in the target filesystem.
 
+choice
+       prompt "Root FS skeleton"
+
+config BR2_ROOTFS_SKELETON_DEFAULT
+       bool "default target skeleton"
+       help
+         Use default target skeleton
+
+config BR2_ROOTFS_SKELETON_CUSTOM
+       bool "custom target skeleton"
+       help
+         Use custom target skeleton.
+
+endchoice
+
+if BR2_ROOTFS_SKELETON_CUSTOM
+config BR2_ROOTFS_SKELETON_CUSTOM_PATH
+       string "custom target skeleton path"
+       default "fs/skeleton"
+       help
+         Path custom target skeleton.
+endif
+
 source "fs/cramfs/Config.in"
 source "fs/cloop/Config.in"
 source "fs/ext2/Config.in"