package/janus-gateway: fix libogg dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 20 Jun 2020 14:35:00 +0000 (16:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Jun 2020 20:20:59 +0000 (22:20 +0200)
libogg is not only used for voicemail plugin, it is an optional
dependency of:
- audiobridge plugin since version 0.9.3 and
  https://github.com/meetecho/janus-gateway/commit/53761d07c5456424d368c708fda2757e6606a4bf
- streaming plugin since version 0.9.3 and
  https://github.com/meetecho/janus-gateway/commit/d9aa1cec84c662f2f7fda025ee023f6dec927bdc

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/janus-gateway/janus-gateway.mk

index 56b7d67332815d270e068222efd0d9ede7ea2fd6..94d83eb33e8437ec75ddaa122d08eb3a4739918d 100644 (file)
@@ -11,7 +11,8 @@ JANUS_GATEWAY_LICENSE_FILES = COPYING
 
 # ding-libs provides the ini_config library
 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
-       libsrtp host-gengetopt libglib2 openssl libconfig
+       libsrtp host-gengetopt libglib2 openssl libconfig \
+       $(if $(BR2_PACKAGE_LIBOGG),libogg)
 
 # Straight out of the repository, no ./configure, and we also patch
 # configure.ac.
@@ -72,7 +73,6 @@ JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videoroom
 endif
 
 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_VOICE_MAIL),y)
-JANUS_GATEWAY_DEPENDENCIES += libogg
 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
 else
 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail