xorriso: Add host variant
authorBenoît Allard <benoit.allard@greenbone.net>
Wed, 16 Mar 2016 13:55:15 +0000 (14:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 19:09:05 +0000 (21:09 +0200)
Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/xorriso/Config.in.host [new file with mode: 0644]
package/xorriso/xorriso.mk

index 09c98fb77f5e362f0559be1182d070bab228563a..a91612b3abe5050e00a5dd0d5aa5f509318360a3 100644 (file)
@@ -32,6 +32,7 @@ menu "Host utilities"
        source "package/uboot-tools/Config.in.host"
        source "package/util-linux/Config.in.host"
        source "package/vboot-utils/Config.in.host"
+       source "package/xorriso/Config.in.host"
        source "package/zip/Config.in.host"
 
 endmenu
diff --git a/package/xorriso/Config.in.host b/package/xorriso/Config.in.host
new file mode 100644 (file)
index 0000000..2baa043
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_HOST_XORRISO
+       bool "host xorriso"
+       help
+         xorriso copies file objects from POSIX compliant
+         filesystems into Rock Ridge enhanced ISO 9660 filesystems
+         and allows session-wise manipulation of such filesystems.
+         It can load the management information of existing ISO
+         images and it writes the session results to optical media
+         or to filesystem objects.
+
+         Vice versa xorriso is able to copy file objects out of ISO
+         9660 filesystems.
+
+         https://www.gnu.org/software/xorriso
index e8bb5cbabe0f55445ee6b2952ed4cf322e6e0115..57537e897e8813d25910c6b1ff39393d5083dfd7 100644 (file)
@@ -8,6 +8,16 @@ XORRISO_VERSION = 1.4.2
 XORRISO_SITE = $(BR2_GNU_MIRROR)/xorriso
 XORRISO_LICENSE = GPLv3+
 XORRISO_LICENSE_FILES = COPYING COPYRIGHT
+HOST_XORRISO_DEPENDENCIES =
+# Disable everything until we actually need those feature, and add the correct
+# host-libraries
+HOST_XORRISO_CONF_OPTS = \
+        --disable-zlib \
+        --disable-bzip2 \
+        --disable-libcdio \
+        --disable-libreadline \
+        --disable-libedit \
+        --disable-libacl
 
 ifeq ($(BR2_PACKAGE_LIBICONV),y)
 XORRISO_DEPENDENCIES += libiconv
@@ -64,3 +74,4 @@ XORRISO_CONF_OPTS += --disable-jtethreads
 endif
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))