package/sdl_image: disable dynamic loading of libraries
authorPaul Cercueil <paul@crapouillou.net>
Sun, 12 Jul 2020 19:57:12 +0000 (21:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jul 2020 21:05:35 +0000 (23:05 +0200)
The thing with Buildroot, is that we know in advance what will be in the
root filesystem. Therefore, we don't need SDL_image to probe for the
presence of libpng, libjpeg, libtiff or libwebp and dynamically load
them; SDL_image can be linked to them directly at compilation time.

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sdl_image/sdl_image.mk

index 46a28799cfe86fa1ae4cd093b6fb025f8591cb51..95a03a39569bc40ae6ced3448030cac483517057 100644 (file)
@@ -16,6 +16,10 @@ SDL_IMAGE_CONF_OPTS = \
        --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
        --disable-sdltest \
        --disable-static \
+       --disable-jpg-shared \
+       --disable-png-shared \
+       --disable-tif-shared \
+       --disable-webp-shared \
        --enable-bmp=$(if $(BR2_PACKAGE_SDL_IMAGE_BMP),yes,no) \
        --enable-gif=$(if $(BR2_PACKAGE_SDL_IMAGE_GIF),yes,no) \
        --enable-jpg=$(if $(BR2_PACKAGE_SDL_IMAGE_JPEG),yes,no) \