libffi: fix staging headers cleanup
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Feb 2016 21:17:49 +0000 (22:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Feb 2016 21:22:01 +0000 (22:22 +0100)
The LIBFFI_MOVE_STAGING_HEADERS function is responsible for moving
around libffi headers to a standard location. Once this is done, it
removes the no longer used directory, but does so in $(TARGET_DIR) and
not $(STAGING_DIR). This directory is already cleaned up in
$(TARGET_DIR) in the LIBFFI_REMOVE_TARGET_HEADERS post-install target
hook.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libffi/libffi.mk

index 8f0f72d932982783f9eb0eacdb003d81ab10f174..3373c1712c89c3deb78d2ca573f997f76ffc236a 100644 (file)
@@ -17,7 +17,7 @@ define LIBFFI_MOVE_STAGING_HEADERS
        mv $(STAGING_DIR)/usr/lib/libffi-$(LIBFFI_VERSION)/include/*.h $(STAGING_DIR)/usr/include/
        $(SED) '/^includedir.*/d' -e '/^Cflags:.*/d' \
                $(STAGING_DIR)/usr/lib/pkgconfig/libffi.pc
-       rm -rf $(TARGET_DIR)/usr/lib/libffi-*
+       rm -rf $(STAGING_DIR)/usr/lib/libffi-*
 endef
 
 LIBFFI_POST_INSTALL_STAGING_HOOKS += LIBFFI_MOVE_STAGING_HEADERS