systemd: bump to version 214
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Fri, 18 Jul 2014 13:02:00 +0000 (15:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 18 Jul 2014 19:27:48 +0000 (21:27 +0200)
This patch bumps systemd to version 214.

Changes:

- add new users: systemd-bus-proxy, systemd-network and systemd-resolve.
- remove gtk-doc patch, as it is no longer needed.
- remove attr dependency (extended attributes functions are provided by
  glibc).
- enable nss-myhostname, so local hostname changes are properly handled.
- add hook to install symlink to resolv.conf when using
  systemd-networkd.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd-03-fix-am-path-libgcrypt-no-found.patch [new file with mode: 0644]
package/systemd/systemd-03-fix-no-gtk-doc.patch [deleted file]
package/systemd/systemd-04-fix-am-path-libgcrypt-no-found.patch [deleted file]
package/systemd/systemd.mk

diff --git a/package/systemd/systemd-03-fix-am-path-libgcrypt-no-found.patch b/package/systemd/systemd-03-fix-am-path-libgcrypt-no-found.patch
new file mode 100644 (file)
index 0000000..2287ac5
--- /dev/null
@@ -0,0 +1,145 @@
+Fix AM_PATH_LIBGCRYPT not found
+
+This patch installs a copy of libgcrypt.m4 from the libgcrypt source tarball
+to systemd m4 directory.
+
+Libgcrypt uses a custom m4 macro and not pkg-config to check if the
+development files are available. Though libgcrypt support is optional in
+systemd, this macro should be available whenever autoreconf is used, otherwise
+the re-configuration will fail with:
+
+  configure.ac:616: warning: macro 'AM_PATH_LIBGCRYPT' not found in library
+
+As asking the user to install the development package of libgcrypt on the host
+machine or adding libgcrypt as a build dependency to systemd is not
+acceptable, the required file is added to the m4 directory.
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Index: systemd-213/m4/libgcrypt.m4
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ systemd-213/m4/libgcrypt.m4        2014-06-11 10:41:11.749305509 +0200
+@@ -0,0 +1,123 @@
++dnl Autoconf macros for libgcrypt
++dnl       Copyright (C) 2002, 2004 Free Software Foundation, Inc.
++dnl
++dnl This file is free software; as a special exception the author gives
++dnl unlimited permission to copy and/or distribute it, with or without
++dnl modifications, as long as this notice is preserved.
++dnl
++dnl This file is distributed in the hope that it will be useful, but
++dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++
++dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
++dnl                   [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
++dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
++dnl MINIMUN-VERSION is a string with the version number optionalliy prefixed
++dnl with the API version to also check the API compatibility. Example:
++dnl a MINIMUN-VERSION of 1:1.2.5 won't pass the test unless the installed
++dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1.  Using
++dnl this features allows to prevent build against newer versions of libgcrypt
++dnl with a changed API.
++dnl
++AC_DEFUN([AM_PATH_LIBGCRYPT],
++[ AC_ARG_WITH(libgcrypt-prefix,
++            AC_HELP_STRING([--with-libgcrypt-prefix=PFX],
++                           [prefix where LIBGCRYPT is installed (optional)]),
++     libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
++  if test x$libgcrypt_config_prefix != x ; then
++     if test x${LIBGCRYPT_CONFIG+set} != xset ; then
++        LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
++     fi
++  fi
++
++  AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
++  tmp=ifelse([$1], ,1:1.2.0,$1)
++  if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
++     req_libgcrypt_api=`echo "$tmp"     | sed 's/\(.*\):\(.*\)/\1/'`
++     min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
++  else
++     req_libgcrypt_api=0
++     min_libgcrypt_version="$tmp"
++  fi
++
++  AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
++  ok=no
++  if test "$LIBGCRYPT_CONFIG" != "no" ; then
++    req_major=`echo $min_libgcrypt_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
++    req_minor=`echo $min_libgcrypt_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
++    req_micro=`echo $min_libgcrypt_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
++    libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
++    major=`echo $libgcrypt_config_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
++    minor=`echo $libgcrypt_config_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
++    micro=`echo $libgcrypt_config_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
++    if test "$major" -gt "$req_major"; then
++        ok=yes
++    else
++        if test "$major" -eq "$req_major"; then
++            if test "$minor" -gt "$req_minor"; then
++               ok=yes
++            else
++               if test "$minor" -eq "$req_minor"; then
++                   if test "$micro" -ge "$req_micro"; then
++                     ok=yes
++                   fi
++               fi
++            fi
++        fi
++    fi
++  fi
++  if test $ok = yes; then
++    AC_MSG_RESULT([yes ($libgcrypt_config_version)])
++  else
++    AC_MSG_RESULT(no)
++  fi
++  if test $ok = yes; then
++     # If we have a recent libgcrypt, we should also check that the
++     # API is compatible
++     if test "$req_libgcrypt_api" -gt 0 ; then
++        tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
++        if test "$tmp" -gt 0 ; then
++           AC_MSG_CHECKING([LIBGCRYPT API version])
++           if test "$req_libgcrypt_api" -eq "$tmp" ; then
++             AC_MSG_RESULT([okay])
++           else
++             ok=no
++             AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
++           fi
++        fi
++     fi
++  fi
++  if test $ok = yes; then
++    LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
++    LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
++    ifelse([$2], , :, [$2])
++    if test x"$host" != x ; then
++      libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
++      if test x"$libgcrypt_config_host" != xnone ; then
++        if test x"$libgcrypt_config_host" != x"$host" ; then
++  AC_MSG_WARN([[
++***
++*** The config script $LIBGCRYPT_CONFIG was
++*** built for $libgcrypt_config_host and thus may not match the
++*** used host $host.
++*** You may want to use the configure option --with-libgcrypt-prefix
++*** to specify a matching config script.
++***]])
++        fi
++      fi
++    fi
++  else
++    LIBGCRYPT_CFLAGS=""
++    LIBGCRYPT_LIBS=""
++    ifelse([$3], , :, [$3])
++  fi
++  AC_SUBST(LIBGCRYPT_CFLAGS)
++  AC_SUBST(LIBGCRYPT_LIBS)
++])
diff --git a/package/systemd/systemd-03-fix-no-gtk-doc.patch b/package/systemd/systemd-03-fix-no-gtk-doc.patch
deleted file mode 100644 (file)
index dc236a7..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-Fix deactivation of gtk-doc
-
-The tarball contains the Makefile for building documentation with gtk-doc,
-Unfortunately the AM_CONDITIONAL variable is not the correct one, which
-results in an error when running autoreconf.
-
-This patch fixes this issue.
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
----
-Index: systemd-213/docs/gtk-doc.make
-===================================================================
---- systemd-213.orig/docs/gtk-doc.make 2014-02-14 09:27:47.000000000 +0100
-+++ systemd-213/docs/gtk-doc.make      2014-06-04 15:20:11.976845074 +0200
-@@ -267,7 +267,7 @@
- #
- # Require gtk-doc when making dist
- #
--if HAVE_GTK_DOC
-+if ENABLE_GTK_DOC
- dist-check-gtkdoc: docs
- else
- dist-check-gtkdoc:
diff --git a/package/systemd/systemd-04-fix-am-path-libgcrypt-no-found.patch b/package/systemd/systemd-04-fix-am-path-libgcrypt-no-found.patch
deleted file mode 100644 (file)
index 2287ac5..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-Fix AM_PATH_LIBGCRYPT not found
-
-This patch installs a copy of libgcrypt.m4 from the libgcrypt source tarball
-to systemd m4 directory.
-
-Libgcrypt uses a custom m4 macro and not pkg-config to check if the
-development files are available. Though libgcrypt support is optional in
-systemd, this macro should be available whenever autoreconf is used, otherwise
-the re-configuration will fail with:
-
-  configure.ac:616: warning: macro 'AM_PATH_LIBGCRYPT' not found in library
-
-As asking the user to install the development package of libgcrypt on the host
-machine or adding libgcrypt as a build dependency to systemd is not
-acceptable, the required file is added to the m4 directory.
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Index: systemd-213/m4/libgcrypt.m4
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ systemd-213/m4/libgcrypt.m4        2014-06-11 10:41:11.749305509 +0200
-@@ -0,0 +1,123 @@
-+dnl Autoconf macros for libgcrypt
-+dnl       Copyright (C) 2002, 2004 Free Software Foundation, Inc.
-+dnl
-+dnl This file is free software; as a special exception the author gives
-+dnl unlimited permission to copy and/or distribute it, with or without
-+dnl modifications, as long as this notice is preserved.
-+dnl
-+dnl This file is distributed in the hope that it will be useful, but
-+dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
-+dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-+
-+
-+dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
-+dnl                   [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
-+dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
-+dnl MINIMUN-VERSION is a string with the version number optionalliy prefixed
-+dnl with the API version to also check the API compatibility. Example:
-+dnl a MINIMUN-VERSION of 1:1.2.5 won't pass the test unless the installed
-+dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1.  Using
-+dnl this features allows to prevent build against newer versions of libgcrypt
-+dnl with a changed API.
-+dnl
-+AC_DEFUN([AM_PATH_LIBGCRYPT],
-+[ AC_ARG_WITH(libgcrypt-prefix,
-+            AC_HELP_STRING([--with-libgcrypt-prefix=PFX],
-+                           [prefix where LIBGCRYPT is installed (optional)]),
-+     libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
-+  if test x$libgcrypt_config_prefix != x ; then
-+     if test x${LIBGCRYPT_CONFIG+set} != xset ; then
-+        LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
-+     fi
-+  fi
-+
-+  AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
-+  tmp=ifelse([$1], ,1:1.2.0,$1)
-+  if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
-+     req_libgcrypt_api=`echo "$tmp"     | sed 's/\(.*\):\(.*\)/\1/'`
-+     min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
-+  else
-+     req_libgcrypt_api=0
-+     min_libgcrypt_version="$tmp"
-+  fi
-+
-+  AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
-+  ok=no
-+  if test "$LIBGCRYPT_CONFIG" != "no" ; then
-+    req_major=`echo $min_libgcrypt_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
-+    req_minor=`echo $min_libgcrypt_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
-+    req_micro=`echo $min_libgcrypt_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
-+    libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
-+    major=`echo $libgcrypt_config_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
-+    minor=`echo $libgcrypt_config_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
-+    micro=`echo $libgcrypt_config_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
-+    if test "$major" -gt "$req_major"; then
-+        ok=yes
-+    else
-+        if test "$major" -eq "$req_major"; then
-+            if test "$minor" -gt "$req_minor"; then
-+               ok=yes
-+            else
-+               if test "$minor" -eq "$req_minor"; then
-+                   if test "$micro" -ge "$req_micro"; then
-+                     ok=yes
-+                   fi
-+               fi
-+            fi
-+        fi
-+    fi
-+  fi
-+  if test $ok = yes; then
-+    AC_MSG_RESULT([yes ($libgcrypt_config_version)])
-+  else
-+    AC_MSG_RESULT(no)
-+  fi
-+  if test $ok = yes; then
-+     # If we have a recent libgcrypt, we should also check that the
-+     # API is compatible
-+     if test "$req_libgcrypt_api" -gt 0 ; then
-+        tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
-+        if test "$tmp" -gt 0 ; then
-+           AC_MSG_CHECKING([LIBGCRYPT API version])
-+           if test "$req_libgcrypt_api" -eq "$tmp" ; then
-+             AC_MSG_RESULT([okay])
-+           else
-+             ok=no
-+             AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
-+           fi
-+        fi
-+     fi
-+  fi
-+  if test $ok = yes; then
-+    LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
-+    LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
-+    ifelse([$2], , :, [$2])
-+    if test x"$host" != x ; then
-+      libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
-+      if test x"$libgcrypt_config_host" != xnone ; then
-+        if test x"$libgcrypt_config_host" != x"$host" ; then
-+  AC_MSG_WARN([[
-+***
-+*** The config script $LIBGCRYPT_CONFIG was
-+*** built for $libgcrypt_config_host and thus may not match the
-+*** used host $host.
-+*** You may want to use the configure option --with-libgcrypt-prefix
-+*** to specify a matching config script.
-+***]])
-+        fi
-+      fi
-+    fi
-+  else
-+    LIBGCRYPT_CFLAGS=""
-+    LIBGCRYPT_LIBS=""
-+    ifelse([$3], , :, [$3])
-+  fi
-+  AC_SUBST(LIBGCRYPT_CFLAGS)
-+  AC_SUBST(LIBGCRYPT_LIBS)
-+])
index f7fbf79a54c4ca02c7637ecbfc874eb38e2688eb..2564d78a5bb2ee85bfedc13ccff42b4a6e09953c 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-SYSTEMD_VERSION = 213
+SYSTEMD_VERSION = 214
 SYSTEMD_SITE = http://www.freedesktop.org/software/systemd/
 SYSTEMD_SOURCE = systemd-$(SYSTEMD_VERSION).tar.xz
 SYSTEMD_LICENSE = LGPLv2.1+; GPLv2+ for udev; MIT-like license for few source files listed in README
@@ -44,7 +44,6 @@ SYSTEMD_CONF_OPT += \
        --enable-split-usr \
        --enable-introspection=no \
        --disable-efi \
-       --disable-myhostname \
        --disable-tcpwrap \
        --disable-tests \
        --disable-dbus \
@@ -67,13 +66,6 @@ else
 SYSTEMD_CONF_OPT += --disable-acl
 endif
 
-ifeq ($(BR2_PACKAGE_ATTR),y)
-SYSTEMD_CONF_OPT += --enable-attr
-SYSTEMD_DEPENDENCIES += attr
-else
-SYSTEMD_CONF_OPT += --disable-attr
-endif
-
 ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
 SYSTEMD_CONF_OPT += --enable-gudev
 SYSTEMD_DEPENDENCIES += libglib2
@@ -103,6 +95,10 @@ endif
 
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPT += --enable-networkd
+define SYSTEMD_INSTALL_RESOLVCONF_HOOK
+       ln -sf ../run/systemd/resolve/resolv.conf \
+               $(TARGET_DIR)/etc/resolv.conf
+endef
 else
 SYSTEMD_CONF_OPT += --disable-networkd
 define SYSTEMD_INSTALL_SERVICE_NETWORK
@@ -116,9 +112,6 @@ endif
 
 ifeq ($(BR2_PACKAGE_SYSTEMD_TIMESYNCD),y)
 SYSTEMD_CONF_OPT += --enable-timesyncd
-define SYSTEMD_USER_TIMESYNC
-       systemd-timesync -1 systemd-timesync -1 * - - - Network Time Synchronization
-endef
 else
 SYSTEMD_CONF_OPT += --disable-timesyncd
 endif
@@ -154,12 +147,16 @@ endef
 SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
        SYSTEMD_INSTALL_INIT_HOOK \
        SYSTEMD_INSTALL_MACHINEID_HOOK \
+       SYSTEMD_INSTALL_RESOLVCONF_HOOK \
        SYSTEMD_SANITIZE_PATH_IN_UNITS
 
 define SYSTEMD_USERS
        systemd-journal -1 systemd-journal -1 * /var/log/journal - - Journal
        systemd-journal-gateway -1 systemd-journal-gateway -1 * /var/log/journal - - Journal Gateway
-       $(SYSTEMD_USER_TIMESYNC)
+       systemd-resolve -1 systemd-resolve -1 * - - - Network Name Resolution Manager
+       systemd-bus-proxy -1 systemd-bus-proxy -1 * - - - Proxy D-Bus messages to/from a bus
+       systemd-timesync -1 systemd-timesync -1 * - - - Network Time Synchronization
+       systemd-network -1 systemd-network -1 * - - - Network Manager
 endef
 
 define SYSTEMD_INSTALL_SERVICE_TTY