projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
956823d
)
czmq: fix static build
author
Baruch Siach
<baruch@tkos.co.il>
Fri, 21 Nov 2014 06:04:50 +0000
(08:04 +0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Fri, 21 Nov 2014 09:37:14 +0000
(10:37 +0100)
czmq configure script uses gcc to test zmq linking so libstdc++ is not added
automatically. Do this manually.
Fixes:
http://autobuild.buildroot.net/results/7b7/
7b7f7614206cf9b8fef48f49cb060eca356d4949
/
http://autobuild.buildroot.net/results/b3a/
b3abff021d23ef0f685a44901b6041ba45bd35d7
/
http://autobuild.buildroot.net/results/1f0/
1f033d04231c5f058513cbca0d437b96260fbd7a
/
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/czmq/czmq.mk
patch
|
blob
|
history
diff --git
a/package/czmq/czmq.mk
b/package/czmq/czmq.mk
index d25bf01c63a475e7768d206cd9562e9e95c2ed68..9a127265e39825e64fde171881ae0ac158d3c980 100644
(file)
--- a/
package/czmq/czmq.mk
+++ b/
package/czmq/czmq.mk
@@
-18,6
+18,10
@@
CZMQ_LICENSE_FILES = LICENSE
# host-python, so disable asciidoc entirely.
CZMQ_CONF_ENV = ac_cv_prog_czmq_have_asciidoc=no
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+CZMQ_CONF_OPTS += LIBS=-lstdc++
+endif
+
define CZMQ_CREATE_CONFIG_DIR
mkdir -p $(@D)/config
endef