Add target to print buildroot version
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 11 Mar 2012 11:16:39 +0000 (12:16 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 13 Mar 2012 12:10:29 +0000 (13:10 +0100)
It's convenient to have a target to print the buildroot version, for use
in external scripts calling buildroot.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index d508888b3741425c3b25ea72a781c3974e9f6183..30099d99de597cfee6337c87409e14df9558531d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -48,7 +48,7 @@ export BR2_VERSION_FULL:=$(BR2_VERSION)$(shell $(TOPDIR)/support/scripts/setloca
 noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
        defconfig %_defconfig savedefconfig allyesconfig allnoconfig silentoldconfig release \
        randpackageconfig allyespackageconfig allnopackageconfig \
-       source-check
+       source-check print-version
 
 # Strip quotes and then whitespaces
 qstrip=$(strip $(subst ",,$(1)))
@@ -721,6 +721,9 @@ release:
        bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2
        rm -rf $(OUT) $(OUT).tar
 
+print-version:
+       @echo $(BR2_VERSION_FULL)
+
 ################################################################################
 # GENDOC -- generates the make targets needed to build a specific type of
 #           asciidoc documentation.