openocd: pass --disable-werror to fix build issues
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Jan 2015 19:32:47 +0000 (20:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Jan 2015 19:32:47 +0000 (20:32 +0100)
Should fix:

  http://autobuild.buildroot.org/results/91d/91d2ae34f14f1978e0985e75f803055d51201a93/

and similar build problems.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openocd/openocd.mk

index b0bcb7e13976081155242696fee0bfc35702f7f0..c67691c55e789205b769100c6c8c886eec008ab7 100644 (file)
@@ -16,7 +16,8 @@ OPENOCD_CONF_OPTS = \
        --disable-doxygen-html \
        --with-jim-shared=no \
        --disable-shared \
-       --enable-dummy
+       --enable-dummy \
+       --disable-werror
 
 # Rely on the Config.in options of each individual adapter selecting
 # the dependencies they need.
@@ -93,7 +94,8 @@ HOST_OPENOCD_CONF_OPTS = \
        --disable-doxygen-html \
        --with-jim-shared=no \
        --disable-shared \
-       --enable-dummy
+       --enable-dummy \
+       --disable-werror
 
 HOST_OPENOCD_DEPENDENCIES = host-libftdi host-libusb host-libusb-compat