package/qt5quickcontrols: always use the opensource license
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 23 Apr 2017 20:31:02 +0000 (22:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Apr 2017 13:53:34 +0000 (15:53 +0200)
We never ask the user to confirm their assent about the use of a free
license; there is no reason we do so for Qt.

The output of legal-info is there to gather all the licenses used in a
build; the license for qt5quickcontrols will be there to be consulted
as well.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Julien Corjon <corjon.j@ecagroup.com>
Cc: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5quickcontrols/qt5quickcontrols.mk

index d28993244eae6ac95f5f3e626b487e2abc992c7e..5fee6ff424e59fcca8ec6c1a147dc47c66b854a4 100644 (file)
@@ -10,13 +10,8 @@ QT5QUICKCONTROLS_SOURCE = qtquickcontrols-opensource-src-$(QT5QUICKCONTROLS_VERS
 QT5QUICKCONTROLS_DEPENDENCIES = qt5base qt5declarative
 QT5QUICKCONTROLS_INSTALL_STAGING = YES
 
-ifeq ($(BR2_PACKAGE_QT5BASE_LICENSE_APPROVED),y)
 QT5QUICKCONTROLS_LICENSE = GPL-2.0 or GPL-3.0 or LGPL-3.0, GFDL-1.3 (docs)
 QT5QUICKCONTROLS_LICENSE_FILES = LICENSE.GPLv2 LICENSE.GPLv3 LICENSE.LGPLv3 LICENSE.FDL
-else
-QT5QUICKCONTROLS_LICENSE = Commercial license
-QT5QUICKCONTROLS_REDISTRIBUTE = NO
-endif
 
 define QT5QUICKCONTROLS_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_MAKE_ENV) $(HOST_DIR)/usr/bin/qmake)