python2: Fix disabling module bsddb
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 21 May 2014 11:47:44 +0000 (13:47 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 26 May 2014 10:13:38 +0000 (12:13 +0200)
Using this minimal defconfig

BR2_TOOLCHAIN_EXTERNAL=y
BR2_PACKAGE_PYTHON=y
BR2_PACKAGE_BERKELEYDB=y

the current code does not prevent the build of

output/build/python-2.7.6/Modules/_bsddb.o

because the module is really called _bsddb,
see python-2.7.6/Modules/_bsddb.c, line 9604.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python/python-110-optional-db.patch

index ea756daa8f289cb2cdcf11b3df7587fd78e88525..a3e5fe8efce2831307c97037fab4cd3c60345f0e 100644 (file)
@@ -70,7 +70,7 @@ Index: b/configure.ac
 +      AS_HELP_STRING([--disable-bsddb], [disable BerkeyleyDB]),
 +      [ if test "$enableval" = "no"; then
 +           BSDDB=no
-+           DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bsddb"
++           DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _bsddb"
 +        else
 +           BSDDB=yes
 +        fi], [ BSDDB=yes ])