package/kodi: remove optional libtheora support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 5 Apr 2020 13:07:59 +0000 (15:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 5 Apr 2020 14:25:43 +0000 (16:25 +0200)
Kodi plays these files through ffmpeg and does not link to libtheora
anymore, see PR 9686.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/kodi/Config.in
package/kodi/kodi.mk

index 22f6a2778deb08f52ace6538a71ad6fa4f14678c..caf31d4be32d79b49b7ec9841d2a22e7239ff441 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2020.05"
 
+config BR2_PACKAGE_KODI_LIBTHEORA
+       bool "libtheora support in Kodi was removed"
+       select BR2_LEGACY
+       help
+         Kodi does not need libtheora
+
 config BR2_PACKAGE_CEGUI06
        bool "BR2_PACKAGE_CEGUI06 was renamed"
        select BR2_PACKAGE_CEGUI
index 07128ac3c539b97a14f8aa25d98c6d0c600c6349..f5b37cf7d26f59c7826c5648c6c2a2e51371f0e8 100644 (file)
@@ -251,13 +251,6 @@ config BR2_PACKAGE_KODI_LIBSMBCLIENT
        help
          Enable Samba support
 
-config BR2_PACKAGE_KODI_LIBTHEORA
-       bool "theora"
-       select BR2_PACKAGE_LIBTHEORA
-       help
-         Enable Theora input support.
-         Select this if you want to play back OGG/OGV files (Video).
-
 config BR2_PACKAGE_KODI_LIBUSB
        bool "usb"
        # https://github.com/xbmc/xbmc/blob/Jarvis/configure.ac#L1554
index 71b6d444156bf33231aee721fa85754c7300433e..0c4704ea84ddfd572d414d9955185626d763307f 100644 (file)
@@ -315,10 +315,6 @@ ifeq ($(BR2_PACKAGE_LIRC_TOOLS),y)
 KODI_DEPENDENCIES += lirc-tools
 endif
 
-ifeq ($(BR2_PACKAGE_KODI_LIBTHEORA),y)
-KODI_DEPENDENCIES += libtheora
-endif
-
 # kodi needs libva & libva-glx
 ifeq ($(BR2_PACKAGE_KODI_LIBVA)$(BR2_PACKAGE_MESA3D_DRI_DRIVER),yy)
 KODI_DEPENDENCIES += mesa3d libva