package/smack: bear the kernel options munging
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 4 Apr 2020 12:10:28 +0000 (14:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 1 May 2020 13:50:28 +0000 (15:50 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/linux.mk
package/smack/smack.mk

index c122ab70e0f3df88d65fdb4f7f5970c41efdfe9e..ca5dd692d78dee6e8ac3ebd8a4698c484bc44ed8 100644 (file)
@@ -357,10 +357,6 @@ define LINUX_KCONFIG_FIXUP_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_NET))
        $(if $(BR2_PACKAGE_LINUX_TOOLS_PERF),
                $(call KCONFIG_ENABLE_OPT,CONFIG_PERF_EVENTS))
-       $(if $(BR2_PACKAGE_SMACK),
-               $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_SMACK)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_NETWORK))
        $(if $(BR2_PACKAGE_SUNXI_MALI_MAINLINE_DRIVER),
                $(call KCONFIG_ENABLE_OPT,CONFIG_CMA)
                $(call KCONFIG_ENABLE_OPT,CONFIG_DMA_CMA))
index d2ac005ab9112e3c2181f611301d5864d2a38cdd..b7b656e6446236514ef9a7fab7ed99120feffaea 100644 (file)
@@ -14,4 +14,10 @@ SMACK_DEPENDENCIES = host-pkgconf
 # Sources from GitHub, no configure script included.
 SMACK_AUTORECONF = YES
 
+define SMAKE_LINUX_CONFIG_FIXUPS
+       $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_SMACK)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_NETWORK)
+endef
+
 $(eval $(autotools-package))