libiconv: strip installed library and remove the preloadable library
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Fri, 12 Dec 2008 09:03:47 +0000 (09:03 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Fri, 12 Dec 2008 09:03:47 +0000 (09:03 -0000)
This patch is mainly for size reduction, removing more than half the
needed footprint.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/libiconv/libiconv.mk

index 2026991c0609781b60989627422b97379f98a05c..9153d0504a1c9cf4fa509eeccc681f04cc43fa3b 100644 (file)
@@ -16,3 +16,11 @@ LIBICONV_DEPENDENCIES = uclibc
 
 $(eval $(call AUTOTARGETS,package,libiconv))
 
+$(LIBICONV_HOOK_POST_INSTALL):
+       # Remove not used preloadable libiconv.so
+       rm -f $(STAGING_DIR)/usr/lib/preloadable_libiconv.so
+       rm -f $(TARGET_DIR)/usr/lib/preloadable_libiconv.so
+ifneq ($(BR2_ENABLE_DEBUG),y)
+       $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libiconv.so.*
+endif
+       touch $@