package/pkg-autotools: disable NLS for host packages by default
authorVadim Kochan <vadim4j@gmail.com>
Thu, 4 Apr 2019 09:56:12 +0000 (12:56 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 4 Apr 2019 20:47:25 +0000 (22:47 +0200)
There is no need for language translaion feature for the host
packages, anyway some of them disable it explicitly, so lets do it
automatically at least for the host-autotools- kind of packages.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/acl/acl.mk
package/attr/attr.mk
package/gcc/gcc-initial/gcc-initial.mk
package/gutenprint/gutenprint.mk
package/pkg-autotools.mk
package/vim/vim.mk

index 038bc7a0504f3fd39e4933f6cb6ee837aa479f97..8dce274150f5c840b7c0efc978e5bfd3fee885ec 100644 (file)
@@ -15,7 +15,6 @@ HOST_ACL_DEPENDENCIES = host-attr
 ACL_INSTALL_STAGING = YES
 
 ACL_CONF_OPTS = --disable-nls
-HOST_ACL_CONF_OPTS = --disable-nls
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))
index 348dcd2f87b5c2057844f04ad7b20c35ef9796f0..ba77e802d2cb34eee7422f21be3461b81ad262c3 100644 (file)
@@ -12,7 +12,6 @@ ATTR_LICENSE_FILES = doc/COPYING doc/COPYING.LGPL
 ATTR_INSTALL_STAGING = YES
 
 ATTR_CONF_OPTS = --disable-nls
-HOST_ATTR_CONF_OPTS = --disable-nls
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))
index 1decca8259b43606b2ed5f03faf95a13bd3f589f..f5bc6c5b7708da180305d542e3d2e4351393b34b 100644 (file)
@@ -38,7 +38,6 @@ HOST_GCC_INITIAL_CONF_OPTS = \
        --disable-threads \
        --with-newlib \
        --disable-largefile \
-       --disable-nls \
        $(call qstrip,$(BR2_EXTRA_GCC_CONFIG_OPTIONS))
 
 HOST_GCC_INITIAL_CONF_ENV = \
index 65b8d310915305589c4bffaec9988c92da5cfb4f..6c42319977156dd83f9c78e3f138eb848ba542b8 100644 (file)
@@ -61,8 +61,6 @@ HOST_GUTENPRINT_CONF_OPTS = \
        --disable-samples \
        --without-gimp2 \
        --without-doc \
-       --disable-nls \
-       --disable-nls-macos \
        --without-foomatic \
        --without-foomatic3 \
        --disable-escputil \
index 45de99356f5fd363c474109f6aa3e7edd7e6ed39..daa688dab6dc048ca888593edd423aeba7b596cf 100644 (file)
@@ -232,6 +232,7 @@ define $(2)_CONFIGURE_CMDS
                --disable-debug \
                --with-xmlto=no \
                --with-fop=no \
+               --disable-nls \
                $$(if $$($$(PKG)_OVERRIDE_SRCDIR),,--disable-dependency-tracking) \
                $$(QUIET) $$($$(PKG)_CONF_OPTS) \
        )
index 56716cbdd05b745239882ba017fcff1518fbf019..c19d835632451fb94f1462b6c9cdb908bc8e6425 100644 (file)
@@ -86,8 +86,7 @@ HOST_VIM_CONF_OPTS = \
        --without-x \
        --disable-acl \
        --disable-gpm \
-       --disable-selinux \
-       --disable-nls
+       --disable-selinux
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))