audit: Add systemd support
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Sun, 4 Oct 2015 17:29:34 +0000 (19:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 11 Oct 2015 14:06:44 +0000 (16:06 +0200)
The main .service file is installed by audit.
We are using tmpfiles mechanisms to create the log directory, which
would not exists otherwise since /var/log points to /tmp

[Thomas: add explicit --disable-systemd when systemd is not used.]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/audit/audit.mk
package/audit/audit_tmpfiles.conf [new file with mode: 0644]

index 754813582274ffad14131036d23646f54d50985d..329f8c5aca13c8cc4c1c9410b5477f61263ff51b 100644 (file)
@@ -31,10 +31,26 @@ ifeq ($(BR2_aarch64),y)
 AUDIT_CONF_OPTS += --with-aarch64
 endif
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+AUDIT_CONF_OPTS += --enable-systemd
+else
+AUDIT_CONF_OPTS += --disable-systemd
+endif
+
 define AUDIT_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 755 package/audit/S01auditd $(TARGET_DIR)/etc/init.d/S01auditd
 endef
 
+define AUDIT_INSTALL_INIT_SYSTEMD
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -fs ../../../../usr/lib/systemd/system/auditd.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/auditd.service
+
+       mkdir -p $(TARGET_DIR)/usr/lib/tmpfiles.d
+       $(INSTALL) -D -m 644 package/audit/audit_tmpfiles.conf \
+               $(TARGET_DIR)/usr/lib/tmpfiles.d/audit.conf
+endef
+
 define AUDIT_INSTALL_CLEANUP
        $(RM) -rf $(TARGET_DIR)/etc/rc.d
        $(RM) -rf $(TARGET_DIR)/etc/sysconfig
diff --git a/package/audit/audit_tmpfiles.conf b/package/audit/audit_tmpfiles.conf
new file mode 100644 (file)
index 0000000..6b8325b
--- /dev/null
@@ -0,0 +1 @@
+d /var/log/audit 0755 - -